diff CMakeLists.txt @ 1046:00f9f36bcd94

on-the-fly conversion of JSON to XML according to HTTP Accept
author Sebastien Jodogne <s.jodogne@gmail.com>
date Fri, 18 Jul 2014 17:15:34 +0200
parents 0bfeeb6d340f
children 804a75413ee7
line wrap: on
line diff
--- a/CMakeLists.txt	Fri Jul 18 16:41:10 2014 +0200
+++ b/CMakeLists.txt	Fri Jul 18 17:15:34 2014 +0200
@@ -34,12 +34,12 @@
 SET(USE_SYSTEM_CURL ON CACHE BOOL "Use the system version of LibCurl")
 SET(USE_SYSTEM_OPENSSL ON CACHE BOOL "Use the system version of OpenSSL")
 SET(USE_SYSTEM_ZLIB ON CACHE BOOL "Use the system version of ZLib")
+SET(USE_SYSTEM_PUGIXML ON CACHE BOOL "Use the system version of Pugixml)")
 
 # Experimental options
 SET(USE_PLUSTACHE OFF CACHE BOOL "Use the Plustache templating engine (experimental)")
-SET(USE_PUGIXML OFF CACHE BOOL "Use the Pugixml parser (experimental)")
+SET(USE_PUGIXML ON CACHE BOOL "Use the Pugixml parser (turn off only for debug)")
 SET(USE_SYSTEM_PLUSTACHE OFF CACHE BOOL "Use the system version of Plustache (experimental)")
-SET(USE_SYSTEM_PUGIXML OFF CACHE BOOL "Use the system version of Pugixml (experimental)")
 
 # Distribution-specific settings
 SET(USE_GTEST_DEBIAN_SOURCE_PACKAGE OFF CACHE BOOL "Use the sources of Google Test shipped with libgtest-dev (Debian only)")