diff ViewerPlugin/CMakeLists.txt @ 13:e944d00a8a9e

fix
author Sebastien Jodogne <s.jodogne@gmail.com>
date Thu, 27 Oct 2016 10:01:10 +0200
parents 2d7676b93a0f
children 7a88c614be04
line wrap: on
line diff
--- a/ViewerPlugin/CMakeLists.txt	Thu Oct 27 09:54:28 2016 +0200
+++ b/ViewerPlugin/CMakeLists.txt	Thu Oct 27 10:01:10 2016 +0200
@@ -20,7 +20,7 @@
 SET(USE_SYSTEM_ORTHANC_SDK ON CACHE BOOL "Use the system version of the Orthanc plugin SDK")
 
 # Parameters related to OpenLayers
-SET(USE_SYSTEM_OPENLAYERS ON CACHE BOOL "Use the system version of OpenLayers")
+SET(USE_SYSTEM_OPENLAYERS OFF CACHE BOOL "Use the system version of OpenLayers")
 SET(OPENLAYERS_CSS "" CACHE FILEPATH "Path to the system version of OpenLayers CSS")
 SET(OPENLAYERS_JS "" CACHE FILEPATH "Path to the system version of OpenLayers JavaScript")
 
@@ -39,6 +39,7 @@
 include(CheckLibraryExists)
 include(FindPythonInterp)
 include(FindPkgConfig)
+include(CheckSymbolExists)
 
 include(${ORTHANC_ROOT}/Resources/CMake/Compiler.cmake)
 include(${ORTHANC_ROOT}/Resources/CMake/AutoGeneratedCode.cmake)
@@ -128,6 +129,14 @@
     )
 
 else()
+  if (OPENLAYERS_CSS STREQUAL "")
+    message(FATAL_ERROR "The option OPENLAYERS_CSS is not set")
+  endif()
+
+  if (OPENLAYERS_JS STREQUAL "")
+    message(FATAL_ERROR "The option OPENLAYERS_JS is not set")
+  endif()
+
   set(OPENLAYERS_RESOURCES
     OPENLAYERS_CSS  ${OPENLAYERS_CSS}
     OPENLAYERS_JS   ${OPENLAYERS_JS}