diff ViewerPlugin/CMakeLists.txt @ 141:c9271bb5ef94

fix
author Sebastien Jodogne <s.jodogne@gmail.com>
date Tue, 17 Apr 2018 20:04:56 +0200
parents a0f9a3df1110
children faabdb7f2003
line wrap: on
line diff
--- a/ViewerPlugin/CMakeLists.txt	Tue Apr 17 15:47:47 2018 +0200
+++ b/ViewerPlugin/CMakeLists.txt	Tue Apr 17 20:04:56 2018 +0200
@@ -39,6 +39,7 @@
 set(ENABLE_PNG ON)
 set(ENABLE_JPEG ON)
 
+include(${ORTHANC_ROOT}/Resources/CMake/VisualStudioPrecompiledHeaders.cmake)
 include(${ORTHANC_ROOT}/Resources/CMake/OrthancFrameworkConfiguration.cmake)
 include_directories(${ORTHANC_ROOT})
 
@@ -65,6 +66,10 @@
 ## Platform-specific configuration
 #####################################################################
 
+add_definitions(
+  -DHAS_ORTHANC_EXCEPTION=1
+  )
+
 if (${CMAKE_SYSTEM_NAME} STREQUAL "Linux" OR
     ${CMAKE_SYSTEM_NAME} STREQUAL "kFreeBSD" OR
     ${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD")