diff Applications/CMakeLists.txt @ 141:c9271bb5ef94

fix
author Sebastien Jodogne <s.jodogne@gmail.com>
date Tue, 17 Apr 2018 20:04:56 +0200
parents a0f9a3df1110
children 442102e14933
line wrap: on
line diff
--- a/Applications/CMakeLists.txt	Tue Apr 17 15:47:47 2018 +0200
+++ b/Applications/CMakeLists.txt	Tue Apr 17 20:04:56 2018 +0200
@@ -48,6 +48,7 @@
 SET(ENABLE_ZLIB ON)
 SET(HAS_EMBEDDED_RESOURCES ON)
 
+include(${ORTHANC_ROOT}/Resources/CMake/VisualStudioPrecompiledHeaders.cmake)
 include(${ORTHANC_ROOT}/Resources/CMake/OrthancFrameworkConfiguration.cmake)
 include_directories(${ORTHANC_ROOT})
 
@@ -116,6 +117,10 @@
   SRGB_ICC_PROFILE          ${ORTHANC_WSI_DIR}/Resources/sRGB.icc
   )
 
+add_definitions(
+  -DHAS_ORTHANC_EXCEPTION=1
+  )
+
 
 #####################################################################
 ## Setup precompiled headers for Microsoft Visual Studio