diff ViewerPlugin/CMakeLists.txt @ 116:a18bfe1fdd62

sync
author Sebastien Jodogne <s.jodogne@gmail.com>
date Thu, 04 Jan 2018 10:49:34 +0100
parents a3e8ac8b7256
children 3ddaaad18ec0
line wrap: on
line diff
--- a/ViewerPlugin/CMakeLists.txt	Tue Jan 02 10:01:35 2018 +0100
+++ b/ViewerPlugin/CMakeLists.txt	Thu Jan 04 10:49:34 2018 +0100
@@ -16,8 +16,9 @@
 SET(USE_SYSTEM_LIBJPEG ON CACHE BOOL "Use the system version of libjpeg")
 SET(USE_SYSTEM_LIBPNG ON CACHE BOOL "Use the system version of libpng")
 SET(USE_SYSTEM_OPENJPEG ON CACHE BOOL "Use the system version of OpenJpeg")
+SET(USE_SYSTEM_ORTHANC_SDK ON CACHE BOOL "Use the system version of the Orthanc plugin SDK")
 SET(USE_SYSTEM_ZLIB ON CACHE BOOL "Use the system version of ZLib")
-SET(USE_SYSTEM_ORTHANC_SDK ON CACHE BOOL "Use the system version of the Orthanc plugin SDK")
+set(USE_SYSTEM_UUID ON CACHE BOOL "Use the system version of the uuid library from e2fsprogs")
 
 # Parameters related to OpenLayers
 SET(USE_SYSTEM_OPENLAYERS OFF CACHE BOOL "Use the system version of OpenLayers")
@@ -35,12 +36,13 @@
 SET(USE_OPENJPEG_JP2 ON)
 SET(ENABLE_LOCALE OFF)         # Disable support for locales (notably in Boost)
 
+include(CheckIncludeFile)
+include(CheckIncludeFileCXX)
 include(CheckIncludeFiles)
-include(CheckIncludeFileCXX)
 include(CheckLibraryExists)
-include(FindPythonInterp)
+include(CheckSymbolExists)
 include(FindPkgConfig)
-include(CheckSymbolExists)
+include(FindPythonInterp)
 
 include(${ORTHANC_ROOT}/Resources/CMake/Compiler.cmake)
 include(${ORTHANC_ROOT}/Resources/CMake/AutoGeneratedCode.cmake)
@@ -52,6 +54,7 @@
 include(${ORTHANC_ROOT}/Resources/CMake/JsonCppConfiguration.cmake)
 include(${ORTHANC_ROOT}/Resources/CMake/LibJpegConfiguration.cmake)
 include(${ORTHANC_ROOT}/Resources/CMake/LibPngConfiguration.cmake)
+include(${ORTHANC_ROOT}/Resources/CMake/UuidConfiguration.cmake)
 include(${ORTHANC_ROOT}/Resources/CMake/ZlibConfiguration.cmake)
 
 # Include components specific to WSI
@@ -59,16 +62,19 @@
 include(${ORTHANC_WSI_DIR}/Resources/CMake/OpenJpegConfiguration.cmake)
 
 add_definitions(
+  -DHAS_ORTHANC_EXCEPTION=1
+  -DORTHANC_DEFAULT_DICOM_ENCODING=Encoding_Latin1
   -DORTHANC_ENABLE_BASE64=0
   -DORTHANC_ENABLE_CURL=0
   -DORTHANC_ENABLE_DCMTK=0
+  -DORTHANC_ENABLE_JPEG=1
   -DORTHANC_ENABLE_LOCALE=0
   -DORTHANC_ENABLE_LOGGING=1
   -DORTHANC_ENABLE_LOGGING_PLUGIN=1
   -DORTHANC_ENABLE_MD5=0
+  -DORTHANC_ENABLE_PNG=1
   -DORTHANC_ENABLE_PUGIXML=0
   -DORTHANC_SANDBOXED=0
-  -DHAS_ORTHANC_EXCEPTION=1
   )
 
 
@@ -229,10 +235,11 @@
   # Mandatory components
   ${BOOST_SOURCES}
   ${JSONCPP_SOURCES}
-  ${ZLIB_SOURCES}
+  ${LIBJPEG_SOURCES}
   ${LIBPNG_SOURCES}
-  ${LIBJPEG_SOURCES}
   ${OPENJPEG_SOURCES}
+  ${UUID_SOURCES}
+  ${ZLIB_SOURCES}
   )
 
 message("Setting the version of the library to ${ORTHANC_WSI_VERSION}")