diff Applications/CMakeLists.txt @ 57:91fc9583b2de

big refactoring to support sparse tiling
author Sebastien Jodogne <s.jodogne@gmail.com>
date Thu, 24 Nov 2016 17:48:24 +0100
parents 175d06fa292e
children 35468714a38e
line wrap: on
line diff
--- a/Applications/CMakeLists.txt	Thu Nov 24 15:41:21 2016 +0100
+++ b/Applications/CMakeLists.txt	Thu Nov 24 17:48:24 2016 +0100
@@ -9,6 +9,7 @@
 # Generic parameters
 SET(STATIC_BUILD OFF CACHE BOOL "Static build of the third-party libraries (necessary for Windows)")
 SET(ALLOW_DOWNLOADS OFF CACHE BOOL "Allow CMake to download packages")
+SET(ENABLE_PROFILING OFF CACHE BOOL "Whether to enable the generation of profiling information with gprof")
 
 # Optional components
 SET(ENABLE_SSL OFF CACHE BOOL "Include support for SSL")
@@ -314,3 +315,23 @@
 else()
   message("Doxygen not found. The documentation will not be built.")
 endif()
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+add_executable(Hello
+  Hello.cpp
+  ApplicationToolbox.cpp
+  )
+
+target_link_libraries(Hello OrthancWSIFramework ${DCMTK_LIBRARIES})