diff ViewerPlugin/CMakeLists.txt @ 8:62adabb8c122

Provide "--version" in command-line tools
author Sebastien Jodogne <s.jodogne@gmail.com>
date Wed, 26 Oct 2016 16:53:54 +0200
parents 77b76c1a213f
children 2d7676b93a0f
line wrap: on
line diff
--- a/ViewerPlugin/CMakeLists.txt	Wed Oct 26 15:42:52 2016 +0200
+++ b/ViewerPlugin/CMakeLists.txt	Wed Oct 26 16:53:54 2016 +0200
@@ -1,8 +1,6 @@
 cmake_minimum_required(VERSION 2.8)
 project(OrthancWSIPlugin)
 
-set(ORTHANC_WSI_VERSION "mainline")
-
 
 #####################################################################
 ## Parameters of the build
@@ -53,6 +51,8 @@
 include(${ORTHANC_ROOT}/Resources/CMake/LibPngConfiguration.cmake)
 include(${ORTHANC_ROOT}/Resources/CMake/ZlibConfiguration.cmake)
 
+# Include components specific to WSI
+include(${ORTHANC_WSI_DIR}/Resources/CMake/Version.cmake)
 include(${ORTHANC_WSI_DIR}/Resources/CMake/OpenJpegConfiguration.cmake)
 
 add_definitions(
@@ -191,8 +191,6 @@
   )
 
 message("Setting the version of the library to ${ORTHANC_WSI_VERSION}")
-add_definitions(-DORTHANC_WSI_VERSION="${ORTHANC_WSI_VERSION}")
-
 set_target_properties(OrthancWSI PROPERTIES 
   VERSION ${ORTHANC_WSI_VERSION} 
   SOVERSION ${ORTHANC_WSI_VERSION})