diff CMakeLists.txt @ 206:d1ed9efdea6c

rename ORTHANC_WEBVIEWER_VERSION as ORTHANC_PLUGIN_VERSION
author Sebastien Jodogne <s.jodogne@gmail.com>
date Fri, 20 Jul 2018 14:25:04 +0200
parents a27f6c89f000
children 2f27287c047c
line wrap: on
line diff
--- a/CMakeLists.txt	Wed Jul 18 15:28:42 2018 +0200
+++ b/CMakeLists.txt	Fri Jul 20 14:25:04 2018 +0200
@@ -21,9 +21,9 @@
 
 project(OrthancWebViewer)
 
-set(ORTHANC_WEBVIEWER_VERSION "mainline")
+set(ORTHANC_PLUGIN_VERSION "mainline")
 
-if (ORTHANC_WEBVIEWER_VERSION STREQUAL "mainline")
+if (ORTHANC_PLUGIN_VERSION STREQUAL "mainline")
   set(ORTHANC_FRAMEWORK_VERSION "mainline")
   set(ORTHANC_FRAMEWORK_DEFAULT_SOURCE "hg")
 else()
@@ -108,7 +108,7 @@
   execute_process(
     COMMAND 
     ${PYTHON_EXECUTABLE} ${ORTHANC_ROOT}/Resources/WindowsResources.py
-    ${ORTHANC_WEBVIEWER_VERSION} "OrthancWebViewer" OrthancWebViewer.dll "Web viewer of medical images for Orthanc"
+    ${ORTHANC_PLUGIN_VERSION} "OrthancWebViewer" OrthancWebViewer.dll "Web viewer of medical images for Orthanc"
     ERROR_VARIABLE Failure
     OUTPUT_FILE ${AUTOGENERATED_DIR}/Version.rc
     )
@@ -156,13 +156,13 @@
 
 target_link_libraries(OrthancWebViewer ${GDCM_LIBRARIES})
 
-message("Setting the version of the library to ${ORTHANC_WEBVIEWER_VERSION}")
+message("Setting the version of the library to ${ORTHANC_PLUGIN_VERSION}")
 
-add_definitions(-DORTHANC_WEBVIEWER_VERSION="${ORTHANC_WEBVIEWER_VERSION}")
+add_definitions(-DORTHANC_PLUGIN_VERSION="${ORTHANC_PLUGIN_VERSION}")
 
 set_target_properties(OrthancWebViewer PROPERTIES 
-  VERSION ${ORTHANC_WEBVIEWER_VERSION} 
-  SOVERSION ${ORTHANC_WEBVIEWER_VERSION})
+  VERSION ${ORTHANC_PLUGIN_VERSION} 
+  SOVERSION ${ORTHANC_PLUGIN_VERSION})
 
 install(
   TARGETS OrthancWebViewer