diff CMakeLists.txt @ 79:abdde1dfb3eb

use sdk 0.9.4
author Sebastien Jodogne <s.jodogne@gmail.com>
date Fri, 25 Sep 2015 12:32:37 +0200
parents f44ebb25691c
children 83496e713a8e
line wrap: on
line diff
--- a/CMakeLists.txt	Fri Sep 25 11:29:17 2015 +0200
+++ b/CMakeLists.txt	Fri Sep 25 12:32:37 2015 +0200
@@ -32,7 +32,6 @@
 set(USE_SYSTEM_GDCM ON CACHE BOOL "Use the system version of Grassroot DICOM (GDCM)")
 set(USE_SYSTEM_GOOGLE_TEST ON CACHE BOOL "Use the system version of Google Test")
 set(USE_SYSTEM_JSONCPP ON CACHE BOOL "Use the system version of JsonCpp")
-set(USE_SYSTEM_ZLIB ON CACHE BOOL "Use the system version of zlib")
 set(USE_SYSTEM_SQLITE ON CACHE BOOL "Use the system version of SQLite")
 set(USE_SYSTEM_ORTHANC_SDK ON CACHE BOOL "Use the system version of the Orthanc plugin SDK")
 
@@ -116,13 +115,8 @@
   list(APPEND AUTOGENERATED_SOURCES  ${AUTOGENERATED_DIR}/Version.rc)
 endif()
 
-if (CMAKE_COMPILER_IS_GNUCXX)
-  SET(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--version-script=${CMAKE_SOURCE_DIR}/Orthanc/Plugins/Samples/Common/VersionScript.map -Wl,--no-undefined")
-endif()
-
 if (APPLE)
   SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -framework CoreFoundation")
-  SET(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -framework CoreFoundation")
 endif()
 
 add_definitions(
@@ -134,22 +128,16 @@
 set(CORE_SOURCES
   ${BOOST_SOURCES}
   ${SQLITE_SOURCES}
-  ${LIBJPEG_SOURCES}
-  ${ZLIB_SOURCES}
-  ${LIBPNG_SOURCES}
   ${JSONCPP_SOURCES}
 
   # Sources inherited from Orthanc core
   ${CMAKE_SOURCE_DIR}/Orthanc/Core/ChunkedBuffer.cpp
   ${CMAKE_SOURCE_DIR}/Orthanc/Core/Enumerations.cpp
   ${CMAKE_SOURCE_DIR}/Orthanc/Core/FileStorage/FilesystemStorage.cpp
-  ${CMAKE_SOURCE_DIR}/Orthanc/Core/ImageFormats/ImageAccessor.cpp
-  ${CMAKE_SOURCE_DIR}/Orthanc/Core/ImageFormats/ImageBuffer.cpp
-  ${CMAKE_SOURCE_DIR}/Orthanc/Core/ImageFormats/ImageProcessing.cpp
-  ${CMAKE_SOURCE_DIR}/Orthanc/Core/ImageFormats/PngReader.cpp
-  ${CMAKE_SOURCE_DIR}/Orthanc/Core/ImageFormats/PngWriter.cpp
+  ${CMAKE_SOURCE_DIR}/Orthanc/Core/Images/ImageAccessor.cpp
+  ${CMAKE_SOURCE_DIR}/Orthanc/Core/Images/ImageBuffer.cpp
+  ${CMAKE_SOURCE_DIR}/Orthanc/Core/Images/ImageProcessing.cpp
   ${CMAKE_SOURCE_DIR}/Orthanc/Core/MultiThreading/SharedMessageQueue.cpp
-  ${CMAKE_SOURCE_DIR}/Orthanc/Core/OrthancException.cpp
   ${CMAKE_SOURCE_DIR}/Orthanc/Core/SQLite/Connection.cpp
   ${CMAKE_SOURCE_DIR}/Orthanc/Core/SQLite/FunctionContext.cpp
   ${CMAKE_SOURCE_DIR}/Orthanc/Core/SQLite/Statement.cpp
@@ -162,7 +150,6 @@
 
   ${CMAKE_SOURCE_DIR}/Plugin/Cache/CacheManager.cpp
   ${CMAKE_SOURCE_DIR}/Plugin/Cache/CacheScheduler.cpp
-  ${CMAKE_SOURCE_DIR}/Plugin/JpegWriter.cpp
   ${CMAKE_SOURCE_DIR}/Plugin/ViewerToolbox.cpp
   ${CMAKE_SOURCE_DIR}/Plugin/SeriesVolumeSorter.cpp
   ${CMAKE_SOURCE_DIR}/Plugin/ViewerPrefetchPolicy.cpp