diff CMakeLists.txt @ 269:938257eebc03

simplification
author Sebastien Jodogne <s.jodogne@gmail.com>
date Wed, 10 Jun 2020 16:47:06 +0200
parents fada2686f2c4
children 3e9307f6da67
line wrap: on
line diff
--- a/CMakeLists.txt	Wed Jun 10 14:54:45 2020 +0200
+++ b/CMakeLists.txt	Wed Jun 10 16:47:06 2020 +0200
@@ -55,20 +55,16 @@
 
 
 # Download and setup the Orthanc framework
-include(${CMAKE_SOURCE_DIR}/Resources/Orthanc/CMake/DownloadOrthancFramework.cmake)
-
-
 if (ORTHANC_FRAMEWORK_SOURCE STREQUAL "system")
-  set(USE_SYSTEM_GOOGLE_TEST ON CACHE BOOL "Use the system version of Google Test")
-  set(USE_GOOGLE_TEST_DEBIAN_PACKAGE OFF CACHE BOOL "Use the sources of Google Test shipped with libgtest-dev (Debian only)")
-  mark_as_advanced(USE_GOOGLE_TEST_DEBIAN_PACKAGE)
-  include(${CMAKE_SOURCE_DIR}/Resources/Orthanc/CMake/GoogleTestConfiguration.cmake)
+  set(ENABLE_GOOGLE_TEST ON)
+  include(${CMAKE_SOURCE_DIR}/Resources/Orthanc/CMake/DownloadOrthancFramework.cmake)
 
   include_directories(
     ${CMAKE_SOURCE_DIR}/Resources/Orthanc/
     )
   link_libraries(OrthancFramework)
 else()
+  include(${CMAKE_SOURCE_DIR}/Resources/Orthanc/CMake/DownloadOrthancFramework.cmake)
   include(${ORTHANC_ROOT}/Resources/CMake/OrthancFrameworkParameters.cmake)
   
   set(ENABLE_LOCALE OFF)         # Disable support for locales (notably in Boost)