diff CMakeLists.txt @ 51:7b4b8b82112e

fix
author Sebastien Jodogne <s.jodogne@gmail.com>
date Thu, 30 Jul 2015 15:56:27 +0200
parents c06f1c00ce56
children 26a230647a73
line wrap: on
line diff
--- a/CMakeLists.txt	Thu Jul 30 15:16:34 2015 +0200
+++ b/CMakeLists.txt	Thu Jul 30 15:56:27 2015 +0200
@@ -64,19 +64,7 @@
 
 # Check that the Orthanc SDK headers are available or download them
 if (STATIC_BUILD)
-  #set(ORTHANC_SDK_URL "https://bitbucket.org/sjodogne/orthanc/raw/default")
-  set(ORTHANC_SDK_URL "https://bitbucket.org/sjodogne/orthanc/raw/Orthanc-0.9.1")
-
-  file(MAKE_DIRECTORY ${AUTOGENERATED_DIR}/orthanc)
-  file(DOWNLOAD 
-    "${ORTHANC_SDK_URL}/Plugins/Include/orthanc/OrthancCPlugin.h"
-    "${AUTOGENERATED_DIR}/orthanc/OrthancCPlugin.h" 
-    STATUS StatusTmp)
-
-  list(GET StatusTmp 0 Status)
-  if(NOT Status EQUAL 0)
-    message(FATAL_ERROR "Cannot download the plugin SDK")
-  endif()
+  include_directories(${ORTHANC_ROOT}/Sdk-0.9.1)
 else ()
   CHECK_INCLUDE_FILE_CXX(orthanc/OrthancCPlugin.h HAVE_ORTHANC_H)
   if (NOT HAVE_ORTHANC_H)