diff CMakeLists.txt @ 231:7097d0eaac76 transcoding

Move the GDCM decoder out of the Orthanc Web viewer plugin as a separate plugin
author Sebastien Jodogne <s.jodogne@gmail.com>
date Mon, 11 May 2020 15:34:12 +0200
parents cce89307af28
children f18f6e7269b3
line wrap: on
line diff
--- a/CMakeLists.txt	Mon May 11 12:06:33 2020 +0200
+++ b/CMakeLists.txt	Mon May 11 15:34:12 2020 +0200
@@ -42,7 +42,6 @@
 set(ORTHANC_FRAMEWORK_ROOT "" CACHE STRING "Path to the Orthanc source directory, if ORTHANC_FRAMEWORK_SOURCE is \"path\"")
 
 # Advanced parameters to fine-tune linking against system libraries
-set(USE_SYSTEM_GDCM ON CACHE BOOL "Use the system version of Grassroot DICOM (GDCM)")
 set(USE_SYSTEM_ORTHANC_SDK ON CACHE BOOL "Use the system version of the Orthanc plugin SDK")
 
 
@@ -60,7 +59,6 @@
 include_directories(${ORTHANC_ROOT})
 
 
-include(${CMAKE_SOURCE_DIR}/Resources/CMake/GdcmConfiguration.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/JavaScriptLibraries.cmake)
 
 
@@ -140,25 +138,14 @@
 
 add_library(OrthancWebViewer
   SHARED
+  ${AUTOGENERATED_SOURCES}
+  ${CMAKE_SOURCE_DIR}/Plugin/DecodedImageAdapter.cpp
+  ${CMAKE_SOURCE_DIR}/Plugin/Plugin.cpp
   ${CORE_SOURCES}
-  ${AUTOGENERATED_SOURCES}
-  ${CMAKE_SOURCE_DIR}/Plugin/Plugin.cpp
   ${ORTHANC_ROOT}/Plugins/Samples/Common/OrthancPluginCppWrapper.cpp
-
-  # The following files depend on GDCM
-  ${CMAKE_SOURCE_DIR}/Plugin/DecodedImageAdapter.cpp
-  ${ORTHANC_ROOT}/Plugins/Samples/GdcmDecoder/GdcmImageDecoder.cpp
-  ${ORTHANC_ROOT}/Plugins/Samples/GdcmDecoder/GdcmDecoderCache.cpp
-  ${ORTHANC_ROOT}/Plugins/Samples/GdcmDecoder/OrthancImageWrapper.cpp
   )
 
 
-if (STATIC_BUILD OR NOT USE_SYSTEM_GDCM)
-  add_dependencies(OrthancWebViewer GDCM)
-endif()
-
-target_link_libraries(OrthancWebViewer ${GDCM_LIBRARIES})
-
 message("Setting the version of the library to ${ORTHANC_PLUGIN_VERSION}")
 
 add_definitions(-DORTHANC_PLUGIN_VERSION="${ORTHANC_PLUGIN_VERSION}")