diff CMakeLists.txt @ 176:55f8cf4ea237

support for Linux Standard Base
author Sebastien Jodogne <s.jodogne@gmail.com>
date Thu, 04 Jan 2018 09:01:14 +0100
parents dd1ad819ca33
children 3f62dac67971
line wrap: on
line diff
--- a/CMakeLists.txt	Thu Jan 04 07:34:54 2018 +0100
+++ b/CMakeLists.txt	Thu Jan 04 09:01:14 2018 +0100
@@ -42,8 +42,13 @@
 mark_as_advanced(USE_GOOGLE_TEST_DEBIAN_PACKAGE)
 
 set(ORTHANC_ROOT ${CMAKE_SOURCE_DIR}/Orthanc)
-set(ORTHANC_DISABLE_PATCH ON)  # No need for the "patch" command-line tool
 set(ENABLE_LOCALE OFF)         # Disable support for locales (notably in Boost)
+
+if (NOT "${CMAKE_SYSTEM_VERSION}" STREQUAL "LinuxStandardBase")
+  # The "patch" command-line tool is only needed for Boost and LSB
+  set(ORTHANC_DISABLE_PATCH ON)
+endif()
+
 include(CheckIncludeFile)
 include(CheckIncludeFiles)
 include(CheckIncludeFileCXX)