diff CMakeLists.txt @ 274:52b56343d268

using OrthancServer/Plugins/Samples/Common/OrthancPluginsExports.cmake
author Sebastien Jodogne <s.jodogne@gmail.com>
date Mon, 06 Jul 2020 08:57:14 +0200
parents 2c3555b8eabc
children 3a9749b1dfce
line wrap: on
line diff
--- a/CMakeLists.txt	Wed Jul 01 11:30:23 2020 +0200
+++ b/CMakeLists.txt	Mon Jul 06 08:57:14 2020 +0200
@@ -48,15 +48,6 @@
 mark_as_advanced(ORTHANC_FRAMEWORK_STATIC)
 
 
-if (${CMAKE_SYSTEM_NAME} STREQUAL "Linux" OR
-    ${CMAKE_SYSTEM_NAME} STREQUAL "kFreeBSD" OR
-    ${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD" OR
-    ${CMAKE_SYSTEM_NAME} STREQUAL "OpenBSD")
-  set(ENABLE_PLUGINS_VERSION_SCRIPT OFF)
-  set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--version-script=${CMAKE_SOURCE_DIR}/Resources/Orthanc/Plugins/VersionScriptPlugins.map")
-endif()
-
-
 # Download and setup the Orthanc framework
 if (ORTHANC_FRAMEWORK_SOURCE STREQUAL "system")
   set(ENABLE_GOOGLE_TEST ON)
@@ -83,6 +74,7 @@
 
 
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/JavaScriptLibraries.cmake)
+include(${CMAKE_SOURCE_DIR}/Resources/Orthanc/Plugins/OrthancPluginsExports.cmake)
 
 
 # Check that the Orthanc SDK headers are available