diff CMakeLists.txt @ 275:3a9749b1dfce

link against system-wide Orthanc Framework
author Sebastien Jodogne <s.jodogne@gmail.com>
date Mon, 06 Jul 2020 11:31:08 +0200
parents 52b56343d268
children 1d360b822973
line wrap: on
line diff
--- a/CMakeLists.txt	Mon Jul 06 08:57:14 2020 +0200
+++ b/CMakeLists.txt	Mon Jul 06 11:31:08 2020 +0200
@@ -52,11 +52,12 @@
 if (ORTHANC_FRAMEWORK_SOURCE STREQUAL "system")
   set(ENABLE_GOOGLE_TEST ON)
   include(${CMAKE_SOURCE_DIR}/Resources/Orthanc/CMake/DownloadOrthancFramework.cmake)
+  link_libraries(${ORTHANC_FRAMEWORK_LIBRARIES})
 
-  include_directories(
-    ${CMAKE_SOURCE_DIR}/Resources/Orthanc/
-    )
-  link_libraries(OrthancFramework)
+  set(USE_SYSTEM_GOOGLE_TEST ON CACHE BOOL "Use the system version of Google Test")
+  set(USE_GOOGLE_TEST_DEBIAN_PACKAGE OFF CACHE BOOL "Use the sources of Google Test shipped with libgtest-dev (Debian only)")
+  mark_as_advanced(USE_GOOGLE_TEST_DEBIAN_PACKAGE)
+  include(${CMAKE_SOURCE_DIR}/Resources/Orthanc/CMake/GoogleTestConfiguration.cmake)
 else()
   include(${CMAKE_SOURCE_DIR}/Resources/Orthanc/CMake/DownloadOrthancFramework.cmake)
   include(${ORTHANC_FRAMEWORK_ROOT}/Resources/CMake/OrthancFrameworkParameters.cmake)
@@ -154,10 +155,6 @@
   ${ORTHANC_CORE_SOURCES}
   )
 
-include_directories(
-  ${CMAKE_SOURCE_DIR}/Resources/Orthanc/Plugins/
-  )
-
 add_library(OrthancWebViewer
   SHARED
   ${AUTOGENERATED_SOURCES}