diff CMakeLists.txt @ 172:330ecfd96aec

sync
author Sebastien Jodogne <s.jodogne@gmail.com>
date Tue, 10 Oct 2017 12:53:46 +0200
parents 38aa615b7667
children 81f16c5667ba
line wrap: on
line diff
--- a/CMakeLists.txt	Thu Aug 24 19:49:20 2017 +0200
+++ b/CMakeLists.txt	Tue Oct 10 12:53:46 2017 +0200
@@ -37,8 +37,8 @@
 set(USE_SYSTEM_ORTHANC_SDK ON CACHE BOOL "Use the system version of the Orthanc plugin SDK")
 
 # Distribution-specific settings
-set(USE_GTEST_DEBIAN_SOURCE_PACKAGE OFF CACHE BOOL "Use the sources of Google Test shipped with libgtest-dev (Debian only)")
-mark_as_advanced(USE_GTEST_DEBIAN_SOURCE_PACKAGE)
+set(USE_GOOGLE_TEST_DEBIAN_PACKAGE OFF CACHE BOOL "Use the sources of Google Test shipped with libgtest-dev (Debian only)")
+mark_as_advanced(USE_GOOGLE_TEST_DEBIAN_PACKAGE)
 
 set(ORTHANC_ROOT ${CMAKE_SOURCE_DIR}/Orthanc)
 set(ORTHANC_DISABLE_PATCH ON)  # No need for the "patch" command-line tool
@@ -92,8 +92,10 @@
   )
 
 add_definitions(
+  -DORTHANC_DEFAULT_DICOM_ENCODING=Encoding_Latin1
   -DORTHANC_ENABLE_LOCALE=0
   -DORTHANC_ENABLE_PUGIXML=0
+  -DORTHANC_ENABLE_SQLITE=1
   -DORTHANC_SQLITE_STANDALONE=1
   )
 
@@ -201,7 +203,7 @@
 
 add_executable(UnitTests
   ${CORE_SOURCES}
-  ${GTEST_SOURCES}
+  ${GOOGLE_TEST_SOURCES}
   ${JSONCPP_SOURCES}
   UnitTestsSources/UnitTestsMain.cpp
   )