diff CMakeLists.txt @ 29:a0af5a8182a8

sync, removed old patch for Orthanc framework 1.5.6
author Sebastien Jodogne <s.jodogne@gmail.com>
date Tue, 04 Aug 2020 14:26:01 +0200
parents 065bc476bcdc
children 3abebab5d004
line wrap: on
line diff
--- a/CMakeLists.txt	Tue Jul 07 20:42:52 2020 +0200
+++ b/CMakeLists.txt	Tue Aug 04 14:26:01 2020 +0200
@@ -20,15 +20,12 @@
 
 set(ORTHANC_PLUGIN_VERSION "mainline")
 
-if (ORTHANC_PLUGIN_VERSION STREQUAL "mainline")
+if (ORTHANC_PLUGIN_VERSION STREQUAL "mainlinea")
   set(ORTHANC_FRAMEWORK_VERSION "mainline")
   set(ORTHANC_FRAMEWORK_DEFAULT_SOURCE "hg")
 else()
-  set(ORTHANC_FRAMEWORK_VERSION "1.5.6")
+  set(ORTHANC_FRAMEWORK_VERSION "1.7.2")
   set(ORTHANC_FRAMEWORK_DEFAULT_SOURCE "web")
-
-  # diff --new-file -urEb Orthanc-1.5.6.orig/ Orthanc-1.5.6 > orthanc-1.5.6.patch
-  set(ORTHANC_FRAMEWORK_PATCH "${CMAKE_SOURCE_DIR}/Resources/Patches/orthanc-1.5.6.patch")
 endif()
 
 
@@ -45,6 +42,8 @@
 # Download and setup the Orthanc framework
 include(${CMAKE_SOURCE_DIR}/Resources/Orthanc/CMake/DownloadOrthancFramework.cmake)
 
+include_directories(${ORTHANC_FRAMEWORK_ROOT})
+
 if (ORTHANC_FRAMEWORK_SOURCE STREQUAL "system")
   link_libraries(${ORTHANC_FRAMEWORK_LIBRARIES})
 
@@ -54,7 +53,7 @@
   include(${CMAKE_SOURCE_DIR}/Resources/Orthanc/CMake/GoogleTestConfiguration.cmake)
 
 else()
-  include(${ORTHANC_FRAMEWORK_ROOT}/Resources/CMake/OrthancFrameworkParameters.cmake)
+  include(${ORTHANC_FRAMEWORK_ROOT}/../Resources/CMake/OrthancFrameworkParameters.cmake)
 
   set(ENABLE_LOCALE OFF)         # Disable support for locales (notably in Boost)
   set(ENABLE_GOOGLE_TEST ON)
@@ -63,31 +62,13 @@
   set(ENABLE_MODULE_DICOM OFF)
   set(ENABLE_ZLIB ON)
 
-  include(${ORTHANC_FRAMEWORK_ROOT}/Resources/CMake/OrthancFrameworkConfiguration.cmake)
-  include_directories(
-    ${ORTHANC_FRAMEWORK_ROOT}/Sources
-    )
+  include(${ORTHANC_FRAMEWORK_ROOT}/../Resources/CMake/OrthancFrameworkConfiguration.cmake)
 endif()
 
 
 include(${CMAKE_SOURCE_DIR}/Resources/Orthanc/Plugins/OrthancPluginsExports.cmake)
 
 
-# Possibly patch the Orthanc framework
-if (DEFINED ORTHANC_FRAMEWORK_PATCH AND
-    NOT EXISTS "${ORTHANC_FRAMEWORK_ROOT}/patched")
-  execute_process(
-    COMMAND ${PATCH_EXECUTABLE} -p0 -N -i ${ORTHANC_FRAMEWORK_PATCH}
-    WORKING_DIRECTORY ${CMAKE_BINARY_DIR}
-    RESULT_VARIABLE Failure
-    )
-
-  if (Failure)
-    message(FATAL_ERROR "Error while patching a file")
-  endif()
-endif()
-
-
 # Check that the Orthanc SDK headers are available
 if (STATIC_BUILD OR NOT USE_SYSTEM_ORTHANC_SDK)
   if (ORTHANC_SDK_VERSION STREQUAL "1.4.2")
@@ -107,7 +88,7 @@
 if (${CMAKE_SYSTEM_NAME} STREQUAL "Windows")
   execute_process(
     COMMAND 
-    ${PYTHON_EXECUTABLE} ${ORTHANC_FRAMEWORK_ROOT}/Resources/WindowsResources.py
+    ${PYTHON_EXECUTABLE} ${ORTHANC_FRAMEWORK_ROOT}/../Resources/WindowsResources.py
     ${ORTHANC_PLUGIN_VERSION} "TransfersAccelerator index plugin" OrthancTransfers.dll
     "TransfersAccelerator as a database back-end to Orthanc (index)"
     ERROR_VARIABLE Failure