diff CMakeLists.txt @ 35:81262707d68e

sync
author Sebastien Jodogne <s.jodogne@gmail.com>
date Sat, 12 Jun 2021 09:35:17 +0200
parents 44a0430d7899
children 49e9245b4005
line wrap: on
line diff
--- a/CMakeLists.txt	Mon Jan 18 15:41:32 2021 +0100
+++ b/CMakeLists.txt	Sat Jun 12 09:35:17 2021 +0200
@@ -24,7 +24,7 @@
   set(ORTHANC_FRAMEWORK_VERSION "mainline")
   set(ORTHANC_FRAMEWORK_DEFAULT_SOURCE "hg")
 else()
-  set(ORTHANC_FRAMEWORK_VERSION "1.7.2")
+  set(ORTHANC_FRAMEWORK_VERSION "1.9.3")
   set(ORTHANC_FRAMEWORK_DEFAULT_SOURCE "web")
 endif()
 
@@ -45,6 +45,17 @@
 include_directories(${ORTHANC_FRAMEWORK_ROOT})
 
 if (ORTHANC_FRAMEWORK_SOURCE STREQUAL "system")
+  if (ORTHANC_FRAMEWORK_USE_SHARED)
+    include(FindBoost)
+    find_package(Boost COMPONENTS thread)
+    
+    if (NOT Boost_FOUND)
+      message(FATAL_ERROR "Unable to locate Boost on this system")
+    endif()
+    
+    link_libraries(${Boost_LIBRARIES} jsoncpp)
+  endif()
+
   link_libraries(${ORTHANC_FRAMEWORK_LIBRARIES})
 
   set(USE_SYSTEM_GOOGLE_TEST ON CACHE BOOL "Use the system version of Google Test")