diff Platforms/WebAssembly/CMakeLists.txt @ 115:f598ffb81cda wasm

fix sandboxed build
author Sebastien Jodogne <s.jodogne@gmail.com>
date Wed, 20 Sep 2017 17:02:58 +0200
parents 3541fc81331a
children c993693e9e63
line wrap: on
line diff
--- a/Platforms/WebAssembly/CMakeLists.txt	Wed Sep 20 16:11:52 2017 +0200
+++ b/Platforms/WebAssembly/CMakeLists.txt	Wed Sep 20 17:02:58 2017 +0200
@@ -6,7 +6,7 @@
 
 
 #####################################################################
-## Configuration of Emscripten for WebAssembly target
+## Configuration of the Emscripten compiler for WebAssembly target
 #####################################################################
 
 set(WASM_FLAGS "-s WASM=1")
@@ -24,15 +24,24 @@
 #set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -s DEMANGLE_SUPPORT=1 -s ASSERTIONS=2")
 
 
-
 #####################################################################
 ## Build a static library containing the Orthanc Stone framework
 #####################################################################
 
-SET(STONE_SANDBOXED ON)
-include(../../Resources/CMake/OrthancStone.cmake)
+include(../../Resources/CMake/OrthancStoneParameters.cmake)
+
+SET(ORTHANC_SANDBOXED ON)
+SET(ENABLE_SDL OFF)
+
+include(../../Resources/CMake/OrthancStoneConfiguration.cmake)
+
 add_library(OrthancStone STATIC ${ORTHANC_STONE_SOURCES})
 
+
+
+
+
+
 # Regenerate a dummy "library.c" file each time the "library.js" file
 # is modified, so as to force a new execution of the linking
 add_custom_command(