diff Platforms/Generic/CMakeLists.txt @ 115:f598ffb81cda wasm

fix sandboxed build
author Sebastien Jodogne <s.jodogne@gmail.com>
date Wed, 20 Sep 2017 17:02:58 +0200
parents 3541fc81331a
children 4c5f7cda8624
line wrap: on
line diff
--- a/Platforms/Generic/CMakeLists.txt	Wed Sep 20 16:11:52 2017 +0200
+++ b/Platforms/Generic/CMakeLists.txt	Wed Sep 20 17:02:58 2017 +0200
@@ -6,8 +6,16 @@
 ## Build a static library containing the Orthanc Stone framework
 #####################################################################
 
-SET(STONE_SANDBOXED OFF)
-include(../../Resources/CMake/OrthancStone.cmake)
+include(../../Resources/CMake/OrthancStoneParameters.cmake)
+
+SET(ORTHANC_SANDBOXED OFF)
+SET(ORTHANC_BOOST_COMPONENTS program_options)
+SET(ENABLE_CRYPTO_OPTIONS ON)
+SET(ENABLE_GOOGLE_TEST ON)
+SET(ENABLE_WEB_CLIENT ON)
+
+include(../../Resources/CMake/OrthancStoneConfiguration.cmake)
+
 add_library(OrthancStone STATIC ${ORTHANC_STONE_SOURCES})