diff Applications/Samples/CMakeLists.txt @ 1190:f417a0ae282b

wip: TextLayer with new fonts
author Alain Mazy <alain@mazy.be>
date Tue, 26 Nov 2019 15:27:48 +0100
parents f2951ac074bd
children 41d19fa749b7
line wrap: on
line diff
--- a/Applications/Samples/CMakeLists.txt	Fri Nov 22 09:51:22 2019 +0100
+++ b/Applications/Samples/CMakeLists.txt	Tue Nov 26 15:27:48 2019 +0100
@@ -9,6 +9,7 @@
 include(../../Resources/CMake/OrthancStoneParameters.cmake)
 
 set(ENABLE_STONE_DEPRECATED ON)  # Need deprecated classes for these samples
+set(EMSCRIPTEN_SET_LLVM_WASM_BACKEND ON)
 
 include(${ORTHANC_ROOT}/Resources/CMake/DownloadPackage.cmake)
 DownloadPackage(
@@ -53,7 +54,7 @@
   set(WASM_FLAGS "${WASM_FLAGS} -s FILESYSTEM=1") # if we don't include it, gen_uuid.c fails to build because srand, getpid(), ... are not defined
   set(WASM_FLAGS "${WASM_FLAGS} -s DISABLE_EXCEPTION_CATCHING=0") # actually enable exception catching 
   set(WASM_FLAGS "${WASM_FLAGS} -s ERROR_ON_MISSING_LIBRARIES=1")
-
+  
   if (CMAKE_BUILD_TYPE MATCHES DEBUG)
     set(WASM_FLAGS "${WASM_FLAGS} -g4") # generate debug information
     set(WASM_FLAGS "${WASM_FLAGS} -s ASSERTIONS=2") # more runtime checks
@@ -238,6 +239,8 @@
       ${SIMPLE_VIEWER_APPLICATION_SOURCES}
       )
     target_link_libraries(OrthancStoneSimpleViewer OrthancStone)
+
+    BuildSingleFileSample(OrthancStoneSingleFrameEditor SingleFrameEditorApplication.h 9)
 endif()
 
 #####################################################################