diff Applications/StoneWebViewer/WebAssembly/CMakeLists.txt @ 2115:de049fd88697 deep-learning

integration mainline->deep-learning
author Sebastien Jodogne <s.jodogne@gmail.com>
date Wed, 24 Jan 2024 16:44:40 +0100
parents a6d5373e471c c23eef785569
children 2e050ec85379
line wrap: on
line diff
--- a/Applications/StoneWebViewer/WebAssembly/CMakeLists.txt	Wed Nov 22 07:44:11 2023 +0100
+++ b/Applications/StoneWebViewer/WebAssembly/CMakeLists.txt	Wed Jan 24 16:44:40 2024 +0100
@@ -1,8 +1,8 @@
 # Stone of Orthanc
 # Copyright (C) 2012-2016 Sebastien Jodogne, Medical Physics
 # Department, University Hospital of Liege, Belgium
-# Copyright (C) 2017-2023 Osimis S.A., Belgium
-# Copyright (C) 2021-2023 Sebastien Jodogne, ICTEAM UCLouvain, Belgium
+# Copyright (C) 2017-2024 Osimis S.A., Belgium
+# Copyright (C) 2021-2024 Sebastien Jodogne, ICTEAM UCLouvain, Belgium
 #
 # This program is free software: you can redistribute it and/or
 # modify it under the terms of the GNU Affero General Public License
@@ -86,7 +86,7 @@
 
 DownloadPackage(
   "a24b8136b8f3bb93f166baf97d9328de"
-  "http://orthanc.osimis.io/ThirdPartyDownloads/ubuntu-font-family-0.83.zip"
+  "https://orthanc.uclouvain.be/downloads/third-party-downloads/ubuntu-font-family-0.83.zip"
   "${CMAKE_BINARY_DIR}/ubuntu-font-family-0.83")
 
 EmbedResources(
@@ -157,7 +157,9 @@
 # Boost::Math begs for -std=c++14 since Boost 1.82.0
 set_property(TARGET StoneWebViewer PROPERTY CXX_STANDARD 14)
 
-DefineSourceBasenameForTarget(StoneWebViewer)
+if (COMMAND DefineSourceBasenameForTarget)
+  DefineSourceBasenameForTarget(StoneWebViewer)
+endif()
 
 set_target_properties(StoneWebViewer
   PROPERTIES