diff Platforms/Generic/CMakeLists.txt @ 127:b963f3a9a86c wasm

fix static build
author Sebastien Jodogne <s.jodogne@gmail.com>
date Wed, 08 Nov 2017 17:53:55 +0100
parents 4c5f7cda8624
children a06ad9d7406e
line wrap: on
line diff
--- a/Platforms/Generic/CMakeLists.txt	Wed Nov 08 17:27:38 2017 +0100
+++ b/Platforms/Generic/CMakeLists.txt	Wed Nov 08 17:53:55 2017 +0100
@@ -15,8 +15,12 @@
 SET(ENABLE_WEB_CLIENT ON)
 
 include(../../Resources/CMake/OrthancStoneConfiguration.cmake)
+include(../../Resources/CMake/BoostExtendedConfiguration.cmake)
 
-add_library(OrthancStone STATIC ${ORTHANC_STONE_SOURCES})
+add_library(OrthancStone STATIC
+  ${ORTHANC_STONE_SOURCES}
+  ${BOOST_EXTENDED_SOURCES}
+  )
 
 
 #####################################################################