diff Applications/StoneWebViewer/Plugin/CMakeLists.txt @ 1877:a2955abe4c2e

skeleton for the RenderingPlugin
author Sebastien Jodogne <s.jodogne@gmail.com>
date Wed, 12 Jan 2022 08:23:38 +0100
parents 7053b8a0aaec
children 07964689cb0b
line wrap: on
line diff
--- a/Applications/StoneWebViewer/Plugin/CMakeLists.txt	Tue Jan 11 21:26:47 2022 +0100
+++ b/Applications/StoneWebViewer/Plugin/CMakeLists.txt	Wed Jan 12 08:23:38 2022 +0100
@@ -69,11 +69,11 @@
   include_directories(${ORTHANC_FRAMEWORK_ROOT})
 endif()
 
-include(${CMAKE_SOURCE_DIR}/../../Resources/Orthanc/Plugins/OrthancPluginsExports.cmake)
+include(${CMAKE_SOURCE_DIR}/../../../RenderingPlugin/Resources/Orthanc/Plugins/OrthancPluginsExports.cmake)
 
 
 if (STATIC_BUILD OR NOT USE_SYSTEM_ORTHANC_SDK)
-  include_directories(${CMAKE_SOURCE_DIR}/../../Resources/Orthanc/Sdk-1.0.0)
+  include_directories(${CMAKE_SOURCE_DIR}/../../../RenderingPlugin/Resources/Orthanc/Sdk-1.0.0)
 else ()
   CHECK_INCLUDE_FILE_CXX(orthanc/OrthancCPlugin.h HAVE_ORTHANC_H)
   if (NOT HAVE_ORTHANC_H)
@@ -128,7 +128,7 @@
 add_library(StoneWebViewer SHARED
   Plugin.cpp
   ${AUTOGENERATED_SOURCES}
-  ${CMAKE_SOURCE_DIR}/../../Resources/Orthanc/Plugins/OrthancPluginCppWrapper.cpp
+  ${CMAKE_SOURCE_DIR}/../../../RenderingPlugin/Resources/Orthanc/Plugins/OrthancPluginCppWrapper.cpp
   ${ORTHANC_CORE_SOURCES}
   )