diff Platforms/Wasm/CMakeLists.txt @ 257:9afafb192180 am-2

using PAM
author am@osimis.io
date Tue, 10 Jul 2018 12:39:01 +0200
parents 65562a28fe05
children dc1beee33134
line wrap: on
line diff
--- a/Platforms/Wasm/CMakeLists.txt	Tue Jul 03 13:19:56 2018 +0200
+++ b/Platforms/Wasm/CMakeLists.txt	Tue Jul 10 12:39:01 2018 +0200
@@ -44,12 +44,12 @@
 add_custom_command(
     OUTPUT "${AUTOGENERATED_DIR}/WasmWebService.c"
     COMMAND ${CMAKE_COMMAND} -E touch "${AUTOGENERATED_DIR}/WasmWebService.c" ""
-    DEPENDS "${ORTHANC_STONE_ROOT}/Platforms/WebAssembly/WasmWebService.js")
+    DEPENDS "${ORTHANC_STONE_ROOT}/Platforms/Wasm/WasmWebService.js")
 
 add_custom_command(
     OUTPUT "${AUTOGENERATED_DIR}/default-library.c"
     COMMAND ${CMAKE_COMMAND} -E touch "${AUTOGENERATED_DIR}/default-library.c" ""
-    DEPENDS "${ORTHANC_STONE_ROOT}/Platforms/WebAssembly/default-library.js")
+    DEPENDS "${ORTHANC_STONE_ROOT}/Platforms/Wasm/default-library.js")
 
 
 #####################################################################
@@ -63,6 +63,9 @@
   add_executable(${Target}
     ${STONE_WASM_SOURCES}
 
+    ${AUTOGENERATED_DIR}/WasmWebService.c
+    ${AUTOGENERATED_DIR}/default-library.c
+
     ${ORTHANC_STONE_ROOT}/Applications/Samples/SampleMainWasm.cpp
 #    ${ORTHANC_STONE_ROOT}/Applications/Samples/SampleApplicationContext.cpp
     ${ORTHANC_STONE_ROOT}/Applications/Samples/SampleInteractor.h