diff Applications/Samples/CMakeLists.txt @ 1089:998d9e4402e0 broker

integration mainline->broker
author Sebastien Jodogne <s.jodogne@gmail.com>
date Wed, 23 Oct 2019 11:04:47 +0200
parents 63539e826355
children f2951ac074bd
line wrap: on
line diff
--- a/Applications/Samples/CMakeLists.txt	Wed Oct 23 10:50:30 2019 +0200
+++ b/Applications/Samples/CMakeLists.txt	Wed Oct 23 11:04:47 2019 +0200
@@ -10,6 +10,15 @@
 
 set(ENABLE_STONE_DEPRECATED ON)  # Need deprecated classes for these samples
 
+include(${ORTHANC_ROOT}/Resources/CMake/DownloadPackage.cmake)
+DownloadPackage(
+  "a24b8136b8f3bb93f166baf97d9328de"
+  "http://orthanc.osimis.io/ThirdPartyDownloads/ubuntu-font-family-0.83.zip"
+  "${CMAKE_BINARY_DIR}/ubuntu-font-family-0.83")
+
+set(ORTHANC_STONE_APPLICATION_RESOURCES
+  UBUNTU_FONT  ${CMAKE_BINARY_DIR}/ubuntu-font-family-0.83/Ubuntu-R.ttf
+  )
 
 if (OPENSSL_NO_CAPIENG)
 add_definitions(-DOPENSSL_NO_CAPIENG=1)