diff Platforms/Generic/CMakeLists.txt @ 280:829163c6efc1 am-2

split MainWindow into a generic one and one specific to these samples
author am@osimis.io
date Mon, 27 Aug 2018 16:22:08 +0200
parents 8f5d7495076d
children 3c190e2bb3af
line wrap: on
line diff
--- a/Platforms/Generic/CMakeLists.txt	Mon Aug 27 15:40:13 2018 +0200
+++ b/Platforms/Generic/CMakeLists.txt	Mon Aug 27 16:22:08 2018 +0200
@@ -29,8 +29,8 @@
 
 LIST(APPEND ORTHANC_BOOST_COMPONENTS program_options)
 
-SET(ENABLE_SDL ON)
-SET(ENABLE_QT OFF)
+SET(ENABLE_SDL OFF)
+SET(ENABLE_QT ON)
 SET(ORTHANC_SANDBOXED OFF)
 SET(ENABLE_CRYPTO_OPTIONS ON)
 SET(ENABLE_GOOGLE_TEST ON)
@@ -47,6 +47,13 @@
 ## Build all the sample applications
 #####################################################################
 
+if (ENABLE_QT)
+  list(APPEND APPLICATIONS_SOURCES
+    ${ORTHANC_STONE_ROOT}/Applications/Samples/Qt/MainWindow.cpp
+    ${ORTHANC_STONE_ROOT}/Applications/Samples/Qt/MainWindow.ui
+    )
+endif()
+
 macro(BuildSample Target Header Sample)
   add_executable(${Target}
     ${ORTHANC_STONE_ROOT}/Applications/Samples/SampleMainNative.cpp