diff Samples/Sdl/CMakeLists.txt @ 848:80829436ce0c am-mainline

starting to re-implement radiography editor with latest framework
author Alain Mazy <alain@mazy.be>
date Thu, 13 Jun 2019 16:47:02 +0200
parents 2fd96a637a59
children 31319fe867b9
line wrap: on
line diff
--- a/Samples/Sdl/CMakeLists.txt	Wed Jun 12 09:52:25 2019 +0200
+++ b/Samples/Sdl/CMakeLists.txt	Thu Jun 13 16:47:02 2019 +0200
@@ -66,7 +66,7 @@
 target_link_libraries(BasicScene OrthancStone)
 
 #
-# BasicScene
+# TrackerSample
 # 
 
 LIST(APPEND TRACKERSAMPLE_SOURCE "TrackerSample.cpp")
@@ -103,3 +103,21 @@
 )
 
 target_link_libraries(FusionMprSdl OrthancStone)
+
+#
+# RadiographyEditor
+#
+
+LIST(APPEND RADIOGRAPHY_EDITOR_SOURCE "../Shared/RadiographyEditorApp.cpp")
+LIST(APPEND RADIOGRAPHY_EDITOR_SOURCE "../Shared/RadiographyEditorApp.h")
+LIST(APPEND RADIOGRAPHY_EDITOR_SOURCE "RadiographyEditor.cpp")
+
+if (MSVC AND MSVC_VERSION GREATER 1700)
+  LIST(APPEND RADIOGRAPHY_EDITOR_SOURCE "cpp.hint")
+endif()
+
+add_executable(RadiographyEditor
+  ${RADIOGRAPHY_EDITOR_SOURCE}
+  )
+
+target_link_libraries(RadiographyEditor OrthancStone)