diff Applications/StoneWebViewer/WebAssembly/CMakeLists.txt @ 1548:65eccce95882

unifying the default install prefix for WebAssembly
author Sebastien Jodogne <s.jodogne@gmail.com>
date Thu, 13 Aug 2020 09:57:35 +0200
parents 8ddf77198ed7
children a48ae10857b1
line wrap: on
line diff
--- a/Applications/StoneWebViewer/WebAssembly/CMakeLists.txt	Wed Aug 12 15:54:55 2020 +0200
+++ b/Applications/StoneWebViewer/WebAssembly/CMakeLists.txt	Thu Aug 13 09:57:35 2020 +0200
@@ -2,6 +2,9 @@
 
 project(OrthancStone)
 
+set(ORTHANC_STONE_INSTALL_PREFIX "${CMAKE_SOURCE_DIR}/../../../wasm-binaries/StoneWebViewer" CACHE PATH "Where to put the WebAssembly binaries")
+
+
 # Configuration of the Emscripten compiler for WebAssembly target
 # ---------------------------------------------------------------
 set(USE_WASM ON CACHE BOOL "")
@@ -98,7 +101,7 @@
 
 install(
   TARGETS StoneWebViewer
-  RUNTIME DESTINATION .
+  RUNTIME DESTINATION ${ORTHANC_STONE_INSTALL_PREFIX}
   )
 
 
@@ -115,7 +118,7 @@
   ${CMAKE_SOURCE_DIR}/../WebApplication/app.js
   ${CMAKE_SOURCE_DIR}/../WebApplication/index.html
   ${STONE_WRAPPER}
-  DESTINATION .
+  DESTINATION ${ORTHANC_STONE_INSTALL_PREFIX}
   )
 
 install(
@@ -125,5 +128,5 @@
   ${CMAKE_SOURCE_DIR}/../WebApplication/img/grid2x1.png
   ${CMAKE_SOURCE_DIR}/../WebApplication/img/grid2x2.png
   ${CMAKE_SOURCE_DIR}/../WebApplication/img/loading.gif
-  DESTINATION img
+  DESTINATION ${ORTHANC_STONE_INSTALL_PREFIX}/img
   )