diff Applications/Samples/WebAssembly/CMakeLists.txt @ 1548:65eccce95882

unifying the default install prefix for WebAssembly
author Sebastien Jodogne <s.jodogne@gmail.com>
date Thu, 13 Aug 2020 09:57:35 +0200
parents 6e0da8370270
children a48ae10857b1
line wrap: on
line diff
--- a/Applications/Samples/WebAssembly/CMakeLists.txt	Wed Aug 12 15:54:55 2020 +0200
+++ b/Applications/Samples/WebAssembly/CMakeLists.txt	Thu Aug 13 09:57:35 2020 +0200
@@ -2,6 +2,9 @@
 
 project(OrthancStone)
 
+set(ORTHANC_STONE_INSTALL_PREFIX "${CMAKE_SOURCE_DIR}/../../../wasm-binaries/" CACHE PATH "Where to put the WebAssembly binaries")
+
+
 # Configuration of the Emscripten compiler for WebAssembly target
 # ---------------------------------------------------------------
 set(USE_WASM ON CACHE BOOL "")
@@ -81,7 +84,7 @@
 # ---------------------------------------------------------------
 install(
   TARGETS RtViewerWasm
-  RUNTIME DESTINATION ${CMAKE_INSTALL_PREFIX}/RtViewer/
+  RUNTIME DESTINATION ${ORTHANC_STONE_INSTALL_PREFIX}/RtViewer/
   )
 
 # Declare installation files for the companion files (web scaffolding)
@@ -95,7 +98,7 @@
   ${CMAKE_SOURCE_DIR}/RtViewer/RtViewerWasmApp.js
   ${CMAKE_SOURCE_DIR}/RtViewer/index.html
   ${CMAKE_CURRENT_BINARY_DIR}/RtViewerWasm.wasm
-  DESTINATION ${CMAKE_INSTALL_PREFIX}/RtViewer/
+  DESTINATION ${ORTHANC_STONE_INSTALL_PREFIX}/RtViewer/
   )
 
 ################################################################################
@@ -115,7 +118,7 @@
 # ---------------------------------------------------------------
 install(
   TARGETS SingleFrameViewerWasm
-  RUNTIME DESTINATION ${CMAKE_INSTALL_PREFIX}/SingleFrameViewer/
+  RUNTIME DESTINATION ${ORTHANC_STONE_INSTALL_PREFIX}/SingleFrameViewer/
   )
 
 # Declare installation files for the companion files (web scaffolding)
@@ -129,5 +132,5 @@
   ${CMAKE_SOURCE_DIR}/SingleFrameViewer/SingleFrameViewerApp.js
   ${CMAKE_SOURCE_DIR}/SingleFrameViewer/index.html
   ${CMAKE_CURRENT_BINARY_DIR}/SingleFrameViewerWasm.wasm
-  DESTINATION ${CMAKE_INSTALL_PREFIX}/SingleFrameViewer/
+  DESTINATION ${ORTHANC_STONE_INSTALL_PREFIX}/SingleFrameViewer/
   )