diff Applications/Samples/RtViewerPlugin/CMakeLists.txt @ 1548:65eccce95882

unifying the default install prefix for WebAssembly
author Sebastien Jodogne <s.jodogne@gmail.com>
date Thu, 13 Aug 2020 09:57:35 +0200
parents 8ddf77198ed7
children 8c5f9864545f
line wrap: on
line diff
--- a/Applications/Samples/RtViewerPlugin/CMakeLists.txt	Wed Aug 12 15:54:55 2020 +0200
+++ b/Applications/Samples/RtViewerPlugin/CMakeLists.txt	Thu Aug 13 09:57:35 2020 +0200
@@ -12,8 +12,8 @@
   set(ORTHANC_FRAMEWORK_DEFAULT_SOURCE "web")
 endif()
 
-set(STONE_BINARIES "${CMAKE_SOURCE_DIR}/../../../wasm-binaries/RtViewer/" CACHE PATH "Path to the binaries of the \"../WebAssembly\" folder")
-
+set(ORTHANC_STONE_BINARIES "${CMAKE_SOURCE_DIR}/../../../wasm-binaries/RtViewer/" CACHE PATH "Path to the binaries of the \"../WebAssembly\" folder")
+ 
 # Parameters of the build
 set(STATIC_BUILD OFF CACHE BOOL "Static build of the third-party libraries (necessary for Windows)")
 set(ALLOW_DOWNLOADS OFF CACHE BOOL "Allow CMake to download packages")
@@ -67,17 +67,17 @@
 
 EmbedResources(
   # Web Viewer Folders
-  # IMAGES                 ${STONE_BINARIES_WEB_VIEWER}/img/
+  # IMAGES                 ${ORTHANC_STONE_BINARIES_WEB_VIEWER}/img/
   # WEB_APPLICATION        ${CMAKE_SOURCE_DIR}/../WebApplication
 
   # Explorer extension code
   ORTHANC_EXPLORER       ${CMAKE_SOURCE_DIR}/OrthancExplorer.js
 
   # RtViewer individual files
-  RT_VIEWER_WASM_JS      ${STONE_BINARIES}/RtViewerWasm.js
-  RT_VIEWER_WASM         ${STONE_BINARIES}/RtViewerWasm.wasm
-  RT_VIEWER_WASM_APP_JS  ${STONE_BINARIES}/RtViewerWasmApp.js
-  RT_VIEWER_INDEX_HTML   ${STONE_BINARIES}/index.html
+  RT_VIEWER_WASM_JS      ${ORTHANC_STONE_BINARIES}/RtViewerWasm.js
+  RT_VIEWER_WASM         ${ORTHANC_STONE_BINARIES}/RtViewerWasm.wasm
+  RT_VIEWER_WASM_APP_JS  ${ORTHANC_STONE_BINARIES}/RtViewerWasmApp.js
+  RT_VIEWER_INDEX_HTML   ${ORTHANC_STONE_BINARIES}/index.html
   )
 
 add_library(RtViewerPlugin SHARED