diff Samples/WebAssembly/RtViewer/CMakeLists.txt @ 1389:5c83be3a6be5

split SDL / common + RtViewer rename + html test file
author Benjamin Golinvaux <bgo@osimis.io>
date Tue, 28 Apr 2020 08:58:41 +0200
parents 24bcff8ea58f
children 27e0a00bd3e8
line wrap: on
line diff
--- a/Samples/WebAssembly/RtViewer/CMakeLists.txt	Tue Apr 28 08:57:39 2020 +0200
+++ b/Samples/WebAssembly/RtViewer/CMakeLists.txt	Tue Apr 28 08:58:41 2020 +0200
@@ -59,20 +59,21 @@
 # Declare installation files for the module
 # ---------------------------------------------------------------
 install(
-  TARGETS CtDoseStructViewerWasm
+  TARGETS RtViewerWasm
   RUNTIME DESTINATION ${CMAKE_INSTALL_PREFIX}
   )
 
 # Declare installation files for the companion files (web scaffolding)
-# please note that ${CMAKE_CURRENT_BINARY_DIR}/SingleFrameViewerWasm.js 
+# please note that ${CMAKE_CURRENT_BINARY_DIR}/RtViewerWasm.js
 # (the generated JS loader for the WASM module) is handled by the `install1`
-# section above
+# section above: it is considered to be the binary output of 
+# the linker.
 # ---------------------------------------------------------------
 install(
   FILES
-  ${CMAKE_SOURCE_DIR}/CtDoseStructViewerApp.js
+  ${CMAKE_SOURCE_DIR}/RtViewerApp.js
   ${CMAKE_SOURCE_DIR}/index.html
-  ${CMAKE_CURRENT_BINARY_DIR}/CtDoseStructViewerWasm.wasm
+  ${CMAKE_CURRENT_BINARY_DIR}/RtViewerWasm.wasm
   ${CMAKE_SOURCE_DIR}/WasmWrapper.js
   DESTINATION ${CMAKE_INSTALL_PREFIX}
   )