diff Applications/Samples/CMakeLists.txt @ 461:593b8c3c02fb am-touch-events

fix build setting + build with ninja
author Alain Mazy <alain@mazy.be>
date Mon, 04 Feb 2019 11:30:24 +0100
parents dc091ca6fd5f
children 801d2697a1b1
line wrap: on
line diff
--- a/Applications/Samples/CMakeLists.txt	Tue Jan 29 18:16:38 2019 +0100
+++ b/Applications/Samples/CMakeLists.txt	Mon Feb 04 11:30:24 2019 +0100
@@ -21,7 +21,7 @@
 
   set(WASM_FLAGS "-s WASM=1")
   set(WASM_FLAGS "${WASM_FLAGS} -s STRICT=1") # drops support for all deprecated build options
-  set(WASM_FLAGS "${WASM_FLAGS} -s FILESYSTEM=0") # remove File system emulation
+  set(WASM_FLAGS "${WASM_FLAGS} -s FILESYSTEM=1") # if we don't include it, gen_uuid.c fails to build because srand, getpid(), ... are not defined
   set(WASM_FLAGS "${WASM_FLAGS} -s DISABLE_EXCEPTION_CATCHING=0") # actually enable exception catching 
   set(WASM_FLAGS "${WASM_FLAGS} -s ERROR_ON_MISSING_LIBRARIES=1")