diff Applications/Samples/WebAssembly/CMakeLists.txt @ 1591:5887a4f8594b

moving platform-specific files out of the "OrthancStone" folder
author Sebastien Jodogne <s.jodogne@gmail.com>
date Fri, 23 Oct 2020 13:15:03 +0200
parents 8c5f9864545f
children 0d4b11ba86df
line wrap: on
line diff
--- a/Applications/Samples/WebAssembly/CMakeLists.txt	Thu Oct 22 18:39:03 2020 +0200
+++ b/Applications/Samples/WebAssembly/CMakeLists.txt	Fri Oct 23 13:15:03 2020 +0200
@@ -49,17 +49,16 @@
 # ---------------------------------------------------------------
 set(ALLOW_DOWNLOADS ON)
 
-include(${CMAKE_SOURCE_DIR}/../../../OrthancStone/Resources/CMake/OrthancStoneParameters.cmake)
+include(${CMAKE_SOURCE_DIR}/../../Platforms/WebAssembly/OrthancStoneWebAssemblyParameters.cmake)
 
 SET(ENABLE_DCMTK OFF)  # Not necessary
 SET(ENABLE_GOOGLE_TEST OFF)
 SET(ENABLE_LOCALE ON)  # Necessary for text rendering
-SET(ENABLE_WASM ON)
 SET(ORTHANC_SANDBOXED ON)
 
 # this will set up the build system for Stone of Orthanc and will
 # populate the ORTHANC_STONE_SOURCES CMake variable
-include(${ORTHANC_STONE_ROOT}/Resources/CMake/OrthancStoneConfiguration.cmake)
+include(${CMAKE_SOURCE_DIR}/../../Platforms/WebAssembly/OrthancStoneWebAssemblyConfiguration.cmake)
 
 
 # We embed a font to be used for on-screen overlays