diff Platforms/Generic/CMakeLists.txt @ 212:5412adf19980

resort to OrthancFramework
author Sebastien Jodogne <s.jodogne@gmail.com>
date Fri, 01 Jun 2018 17:48:47 +0200
parents 6941b98cf0fd
children 07792a582de9
line wrap: on
line diff
--- a/Platforms/Generic/CMakeLists.txt	Mon May 21 09:02:03 2018 +0200
+++ b/Platforms/Generic/CMakeLists.txt	Fri Jun 01 17:48:47 2018 +0200
@@ -3,6 +3,25 @@
 
 
 #####################################################################
+## Configuration for Orthanc
+#####################################################################
+
+include(../../Resources/CMake/Version.cmake)
+
+if (ORTHANC_STONE_VERSION STREQUAL "mainline")
+  set(ORTHANC_FRAMEWORK_VERSION "mainline")
+  set(ORTHANC_FRAMEWORK_DEFAULT_SOURCE "hg")
+else()
+  set(ORTHANC_FRAMEWORK_VERSION "1.3.2")
+  set(ORTHANC_FRAMEWORK_DEFAULT_SOURCE "web")
+endif()
+
+set(ORTHANC_FRAMEWORK_SOURCE "${ORTHANC_FRAMEWORK_DEFAULT_SOURCE}" CACHE STRING "Source of the Orthanc source code (can be \"hg\", \"archive\", \"web\" or \"path\")")
+set(ORTHANC_FRAMEWORK_ARCHIVE "" CACHE STRING "Path to the Orthanc archive, if ORTHANC_FRAMEWORK_SOURCE is \"archive\"")
+set(ORTHANC_FRAMEWORK_ROOT "" CACHE STRING "Path to the Orthanc source directory, if ORTHANC_FRAMEWORK_SOURCE is \"path\"")
+
+
+#####################################################################
 ## Build a static library containing the Orthanc Stone framework
 #####################################################################