diff Samples/Sdl/CMakeLists.txt @ 632:500c3f70b6c2

- Added a ClearAllChains method to PolylineSceneLayer --> revision must change when calling it ==> BumpRevision has been added to base class - Added some docs = Added GetMinDepth + GetMaxDepth to Scene2D (to alleviate the need for app- specific "Z depth registry" : clients may simply add a new layer on top or at the bottom of the existing layer set. - Added the line tracker measurement tools, commands and trackers. Generic base classes + Line measure - started work on the line measure handles
author Benjamin Golinvaux <bgo@osimis.io>
date Thu, 09 May 2019 10:41:31 +0200
parents 97926984d5d0
children b0652595b62a
line wrap: on
line diff
--- a/Samples/Sdl/CMakeLists.txt	Thu May 02 18:58:46 2019 +0200
+++ b/Samples/Sdl/CMakeLists.txt	Thu May 09 10:41:31 2019 +0200
@@ -37,6 +37,7 @@
   UBUNTU_FONT  ${CMAKE_BINARY_DIR}/ubuntu-font-family-0.83/Ubuntu-R.ttf
   )
 
+SET(ENABLE_SDL_CONSOLE OFF CACHE BOOL "Enable the use of the MIT-licensed SDL_Console")
 SET(ENABLE_GOOGLE_TEST OFF)
 SET(ENABLE_LOCALE ON)
 SET(ENABLE_SDL ON)
@@ -46,7 +47,6 @@
 
 include(${CMAKE_SOURCE_DIR}/../../Resources/CMake/OrthancStoneConfiguration.cmake)
 
-
 #####################################################################
 ## Build the samples
 #####################################################################
@@ -60,3 +60,26 @@
   )
 
 target_link_libraries(BasicScene OrthancStone)
+
+if(ENABLE_SDL_CONSOLE)
+  add_definitions(
+    -DENABLE_SDL_CONSOLE=1
+    )
+  LIST(APPEND TRACKERSAMPLE_SOURCE "../../../SDL-Console/SDL_Console.c")
+  LIST(APPEND TRACKERSAMPLE_SOURCE "../../../SDL-Console/SDL_Console.h")
+endif()
+
+LIST(APPEND TRACKERSAMPLE_SOURCE "../Common/MeasureCommands.cpp")
+LIST(APPEND TRACKERSAMPLE_SOURCE "../Common/MeasureCommands.h")
+LIST(APPEND TRACKERSAMPLE_SOURCE "../Common/MeasureTools.cpp")
+LIST(APPEND TRACKERSAMPLE_SOURCE "../Common/MeasureTools.h")
+LIST(APPEND TRACKERSAMPLE_SOURCE "../Common/MeasureTrackers.cpp")
+LIST(APPEND TRACKERSAMPLE_SOURCE "../Common/MeasureTrackers.h")
+LIST(APPEND TRACKERSAMPLE_SOURCE "TrackerSample.cpp")
+
+add_executable(TrackerSample
+  ${TRACKERSAMPLE_SOURCE}
+  )
+
+target_link_libraries(TrackerSample OrthancStone)
+