diff StoneWebViewer/WebAssembly/CMakeLists.txt @ 1518:433cf964838d

prevents random config. names + typofix + doc
author Benjamin Golinvaux <bgo@osimis.io>
date Fri, 31 Jul 2020 12:47:27 +0200
parents 2b7d34cb764f
children
line wrap: on
line diff
--- a/StoneWebViewer/WebAssembly/CMakeLists.txt	Fri Jul 31 12:46:22 2020 +0200
+++ b/StoneWebViewer/WebAssembly/CMakeLists.txt	Fri Jul 31 12:47:27 2020 +0200
@@ -43,6 +43,15 @@
 # populate the ORTHANC_STONE_SOURCES CMake variable
 include(${ORTHANC_STONE_ROOT}/Resources/CMake/OrthancStoneConfiguration.cmake)
 
+if (CMAKE_BUILD_TYPE MATCHES Debug)
+  # specific flags go here
+elseif (CMAKE_BUILD_TYPE MATCHES RelWithDebInfo)
+  # specific flags go here
+elseif (CMAKE_BUILD_TYPE MATCHES Release)
+  # specific flags go here
+else()
+  message(FATAL_ERROR "CMAKE_BUILD_TYPE must match either Debug, RelWithDebInfo or Release" )
+endif()
 
 ################################################################################
 
@@ -95,7 +104,7 @@
 
 # Declare installation files for the companion files (web scaffolding)
 # please note that ${CMAKE_CURRENT_BINARY_DIR}/StoneWebViewer.js
-# (the generated JS loader for the WASM module) is handled by the `install1`
+# (the generated JS loader for the WASM module) is handled by the `install`
 # section above: it is considered to be the binary output of 
 # the linker.
 # ---------------------------------------------------------------