diff Samples/WebAssembly/CMakeLists.txt @ 1471:28c64c246312

working on a shared library
author Sebastien Jodogne <s.jodogne@gmail.com>
date Mon, 15 Jun 2020 12:57:54 +0200
parents 70b0b1dc1de4
children d1dde1f86d4a
line wrap: on
line diff
--- a/Samples/WebAssembly/CMakeLists.txt	Fri Jun 12 17:38:07 2020 +0200
+++ b/Samples/WebAssembly/CMakeLists.txt	Mon Jun 15 12:57:54 2020 +0200
@@ -33,6 +33,7 @@
 set(ORTHANC_FRAMEWORK_SOURCE "path")
 
 include(${STONE_ROOT}/Resources/CMake/OrthancStoneParameters.cmake)
+include(${ORTHANC_ROOT}/Resources/CMake/AutoGeneratedCode.cmake)
 include(${ORTHANC_ROOT}/Resources/CMake/DownloadPackage.cmake)
 
 SET(ENABLE_DCMTK ON)
@@ -41,6 +42,10 @@
 SET(ENABLE_WASM ON)
 SET(ORTHANC_SANDBOXED ON)
 
+# this will set up the build system for Stone of Orthanc and will
+# populate the ORTHANC_STONE_SOURCES CMake variable
+include(${STONE_ROOT}/Resources/CMake/OrthancStoneConfiguration.cmake)
+
 
 # We embed a font to be used for on-screen overlays
 # ---------------------------------------------------------------
@@ -50,16 +55,13 @@
   "http://orthanc.osimis.io/ThirdPartyDownloads/ubuntu-font-family-0.83.zip"
   "${CMAKE_BINARY_DIR}/ubuntu-font-family-0.83")
 
-set(ORTHANC_STONE_APPLICATION_RESOURCES
+EmbedResources(
   UBUNTU_FONT  ${CMAKE_BINARY_DIR}/ubuntu-font-family-0.83/Ubuntu-R.ttf
   )
 
-# this will set up the build system for Stone of Orthanc and will
-# populate the ORTHANC_STONE_SOURCES CMake variable
-include(${STONE_ROOT}/Resources/CMake/OrthancStoneConfiguration.cmake)
-
 add_library(OrthancStone STATIC
   ${ORTHANC_STONE_SOURCES}
+  ${AUTOGENERATED_SOURCES}
   )
 
 ################################################################################