diff Samples/Sdl/RtViewer/CMakeLists.txt @ 1471:28c64c246312

working on a shared library
author Sebastien Jodogne <s.jodogne@gmail.com>
date Mon, 15 Jun 2020 12:57:54 +0200
parents 70b0b1dc1de4
children 9cbc6d21ae89
line wrap: on
line diff
--- a/Samples/Sdl/RtViewer/CMakeLists.txt	Fri Jun 12 17:38:07 2020 +0200
+++ b/Samples/Sdl/RtViewer/CMakeLists.txt	Mon Jun 15 12:57:54 2020 +0200
@@ -7,6 +7,7 @@
 set(STONE_ROOT ${CMAKE_CURRENT_LIST_DIR}/../../../)
 
 include(${STONE_ROOT}/Resources/CMake/OrthancStoneParameters.cmake)
+include(${ORTHANC_ROOT}/Resources/CMake/AutoGeneratedCode.cmake)
 include(${ORTHANC_ROOT}/Resources/CMake/DownloadPackage.cmake)
 
 SET(ENABLE_GOOGLE_TEST OFF)
@@ -17,18 +18,20 @@
 SET(ENABLE_WEB_CLIENT ON)
 SET(ORTHANC_SANDBOXED OFF)
 
+include(${STONE_ROOT}/Resources/CMake/BoostExtendedConfiguration.cmake)
+include(${STONE_ROOT}/Resources/CMake/OrthancStoneConfiguration.cmake)
+include(${STONE_ROOT}/Resources/CMake/Utilities.cmake)
+
 DownloadPackage(
   "a24b8136b8f3bb93f166baf97d9328de"
   "http://orthanc.osimis.io/ThirdPartyDownloads/ubuntu-font-family-0.83.zip"
   "${CMAKE_BINARY_DIR}/ubuntu-font-family-0.83")
 
-set(ORTHANC_STONE_APPLICATION_RESOURCES
+EmbedResources(
+  COLORMAP_HOT ${ORTHANC_STONE_ROOT}/Resources/Colormaps/hot.lut
   UBUNTU_FONT  ${CMAKE_BINARY_DIR}/ubuntu-font-family-0.83/Ubuntu-R.ttf
   )
 
-include(${STONE_ROOT}/Resources/CMake/OrthancStoneConfiguration.cmake)
-include(${STONE_ROOT}/Resources/CMake/Utilities.cmake)
-
 add_definitions(
   -DORTHANC_ENABLE_LOGGING=1
   -DORTHANC_ENABLE_LOGGING_PLUGIN=0
@@ -47,6 +50,7 @@
   ../../Common/RtViewerView.h
   ../../Common/SampleHelpers.h
   ${ORTHANC_STONE_SOURCES}
+  ${AUTOGENERATED_SOURCES}
   )
 
 target_link_libraries(RtViewerSdl ${DCMTK_LIBRARIES})