diff StoneWebViewer/Plugin/CMakeLists.txt @ 1519:22d1bd085c19

split STONE_BINARIES into two different vars for both StoneWebViewer and RtViewer + fixed docker build + embed of RtViewer files + serving of RtViewer files + Orthanc explorer extension to open a series in the RtViewer : sibling series will be traversed and the first DOSE/STRUCT will be used. WARNING: needs work for PT and to allow for missing dose
author Benjamin Golinvaux <bgo@osimis.io>
date Fri, 31 Jul 2020 12:51:28 +0200
parents 244ad1e4e76a
children 61023b0d39c8
line wrap: on
line diff
--- a/StoneWebViewer/Plugin/CMakeLists.txt	Fri Jul 31 12:47:27 2020 +0200
+++ b/StoneWebViewer/Plugin/CMakeLists.txt	Fri Jul 31 12:51:28 2020 +0200
@@ -14,7 +14,8 @@
 
 
 
-set(STONE_BINARIES CACHE PATH "Path to the binaries of the \"../WebAssembly\" folder")
+set(STONE_BINARIES_WEB_VIEWER CACHE PATH "Path to the binaries of the WebViewer \"../WebAssembly\" folder")
+set(STONE_BINARIES_RT_VIEWER CACHE PATH "Path to the binaries of the RtViewer \"../WebAssembly\" folder")
 
 # Parameters of the build
 set(STATIC_BUILD OFF CACHE BOOL "Static build of the third-party libraries (necessary for Windows)")
@@ -70,15 +71,23 @@
 
 
 EmbedResources(
-  # Folders
-  IMAGES                 ${STONE_BINARIES}/img/
+  # Web Viewer Folders
+  IMAGES                 ${STONE_BINARIES_WEB_VIEWER}/img/
   WEB_APPLICATION        ${CMAKE_SOURCE_DIR}/../WebApplication
 
-  # Individual files
+  # Explorer extension code
   ORTHANC_EXPLORER       ${CMAKE_SOURCE_DIR}/OrthancExplorer.js
-  STONE_WEB_VIEWER_JS    ${STONE_BINARIES}/StoneWebViewer.js
-  STONE_WEB_VIEWER_WASM  ${STONE_BINARIES}/StoneWebViewer.wasm
-  STONE_WRAPPER          ${STONE_BINARIES}/stone.js
+
+  # Web viewer individual files
+  STONE_WEB_VIEWER_JS    ${STONE_BINARIES_WEB_VIEWER}/StoneWebViewer.js
+  STONE_WEB_VIEWER_WASM  ${STONE_BINARIES_WEB_VIEWER}/StoneWebViewer.wasm
+  STONE_WRAPPER          ${STONE_BINARIES_WEB_VIEWER}/stone.js
+
+  # RtViewer folder
+  RT_VIEWER_WASM_JS      ${STONE_BINARIES_RT_VIEWER}/RtViewerWasm.js
+  RT_VIEWER_WASM         ${STONE_BINARIES_RT_VIEWER}/RtViewerWasm.wasm
+  RT_VIEWER_WASM_APP_JS  ${STONE_BINARIES_RT_VIEWER}/RtViewerWasmApp.js
+  RT_VIEWER_INDEX_HTML   ${STONE_BINARIES_RT_VIEWER}/index.html
   )
 
 add_library(StoneWebViewer SHARED