diff Samples/Sdl/CMakeLists.txt @ 1426:1e132fe7090e

fix dynamic linking
author Sebastien Jodogne <s.jodogne@gmail.com>
date Fri, 15 May 2020 13:04:34 +0200
parents 95674f9c169a
children 15173a383a00
line wrap: on
line diff
--- a/Samples/Sdl/CMakeLists.txt	Fri May 15 12:28:51 2020 +0200
+++ b/Samples/Sdl/CMakeLists.txt	Fri May 15 13:04:34 2020 +0200
@@ -65,7 +65,7 @@
   ../Common/SampleHelpers.h
   )
 
-target_link_libraries(RtViewerSdl ${DCMTK_LIBRARIES} OrthancStone)
+target_link_libraries(RtViewerSdl OrthancStone ${DCMTK_LIBRARIES})
 
 #############################
 project(SdlSimpleViewer)
@@ -78,7 +78,7 @@
   ${BOOST_EXTENDED_SOURCES}
   )
 
-target_link_libraries(SdlSimpleViewer ${DCMTK_LIBRARIES} OrthancStone)
+target_link_libraries(SdlSimpleViewer OrthancStone ${DCMTK_LIBRARIES})
 
 #############################
 project(UnitTests)
@@ -105,4 +105,4 @@
     "$<TARGET_FILE_DIR:UnitTests>/72c773ac-5059f2c4-2e6a9120-4fd4bca1-45701661.json"
 )
 
-target_link_libraries(UnitTests ${DCMTK_LIBRARIES} OrthancStone)
+target_link_libraries(UnitTests OrthancStone ${DCMTK_LIBRARIES})