diff Applications/StoneWebViewer/WebAssembly/CMakeLists.txt @ 1902:1cfd602de69d

fix wasm build
author Sebastien Jodogne <s.jodogne@gmail.com>
date Sat, 29 Jan 2022 18:30:26 +0100
parents 7053b8a0aaec
children 7947565ed2b7
line wrap: on
line diff
--- a/Applications/StoneWebViewer/WebAssembly/CMakeLists.txt	Sat Jan 29 16:55:14 2022 +0100
+++ b/Applications/StoneWebViewer/WebAssembly/CMakeLists.txt	Sat Jan 29 18:30:26 2022 +0100
@@ -49,7 +49,7 @@
 # ---------------------------------------------------------------
 set(ALLOW_DOWNLOADS ON)
 
-include(${CMAKE_SOURCE_DIR}/../../Platforms/WebAssembly/OrthancStoneWebAssemblyParameters.cmake)
+include(${CMAKE_SOURCE_DIR}/../../../OrthancStone/Resources/CMake/OrthancStoneWebAssemblyParameters.cmake)
 
 SET(ENABLE_DCMTK ON)
 SET(ENABLE_DCMTK_NETWORKING OFF)
@@ -61,12 +61,7 @@
 
 # this will set up the build system for Stone of Orthanc and will
 # populate the ORTHANC_STONE_SOURCES CMake variable
-include(${CMAKE_SOURCE_DIR}/../../Platforms/WebAssembly/OrthancStoneWebAssemblyConfiguration.cmake)
-
-include_directories(
-  ${CMAKE_SOURCE_DIR}/../../../OrthancStone/Sources/
-  ${CMAKE_SOURCE_DIR}/../../Platforms/WebAssembly/
-  )
+include(${CMAKE_SOURCE_DIR}/../../../OrthancStone/Resources/CMake/OrthancStoneWebAssemblyConfiguration.cmake)
 
 if (CMAKE_BUILD_TYPE MATCHES Debug)
   # specific flags go here