diff CMakeLists.txt @ 20:cb7fd3c25f40

added cmake option VTK_BUILD_TYPE
author Sebastien Jodogne <s.jodogne@gmail.com>
date Tue, 12 Sep 2023 13:35:14 +0200
parents c02d12eb34d4
children 48d18eb27477
line wrap: on
line diff
--- a/CMakeLists.txt	Tue Sep 12 12:10:24 2023 +0200
+++ b/CMakeLists.txt	Tue Sep 12 13:35:14 2023 +0200
@@ -65,6 +65,12 @@
 set(USE_SYSTEM_NIFTILIB ON CACHE BOOL "Use the system version of niftilib")
 set(USE_SYSTEM_VTK ON CACHE BOOL "Use the system version of VTK")
 
+# Option "VTK_BUILD_TYPE" is necessary for multi-configuration
+# compilers (such as XCode or MSVC), for "externalproject_add()" to
+# choose the correct build type (which is not known when running
+# "cmake" to configure the project)
+set(VTK_BUILD_TYPE "Release" CACHE STRING "Build type to be used for static builds of VTK (should be \"Debug\" or \"Release\")")
+
 
 #####################################################################
 ## Download and setup the Orthanc framework