diff CMakeLists.txt @ 46:3e2ff3616e57

sync
author Sebastien Jodogne <s.jodogne@gmail.com>
date Tue, 04 Aug 2020 13:31:27 +0200
parents 2468e2f2456c
children 42de8b600c0c
line wrap: on
line diff
--- a/CMakeLists.txt	Mon Aug 03 18:13:10 2020 +0200
+++ b/CMakeLists.txt	Tue Aug 04 13:31:27 2020 +0200
@@ -35,18 +35,19 @@
 # Download and setup the Orthanc framework
 include(${CMAKE_SOURCE_DIR}/Resources/Orthanc/CMake/DownloadOrthancFramework.cmake)
 
+include_directories(${ORTHANC_FRAMEWORK_ROOT})
+
 if (ORTHANC_FRAMEWORK_SOURCE STREQUAL "system")
   #link_libraries(${ORTHANC_FRAMEWORK_LIBRARIES})
 
 else()
-  include(${ORTHANC_FRAMEWORK_ROOT}/Resources/CMake/OrthancFrameworkParameters.cmake)
+  include(${ORTHANC_FRAMEWORK_ROOT}/../Resources/CMake/OrthancFrameworkParameters.cmake)
   
   #set(ENABLE_MODULE_IMAGES OFF CACHE INTERNAL "")
   #set(ENABLE_MODULE_JOBS OFF CACHE INTERNAL "")
   #set(ENABLE_MODULE_DICOM OFF CACHE INTERNAL "")
   
-  include(${ORTHANC_FRAMEWORK_ROOT}/Resources/CMake/OrthancFrameworkConfiguration.cmake)
-  include_directories(${ORTHANC_FRAMEWORK_ROOT}/Sources)
+  include(${ORTHANC_FRAMEWORK_ROOT}/../Resources/CMake/OrthancFrameworkConfiguration.cmake)
 endif()
 
 
@@ -111,7 +112,7 @@
 if (${CMAKE_SYSTEM_NAME} STREQUAL "Windows")
   execute_process(
     COMMAND 
-    ${PYTHON_EXECUTABLE} ${ORTHANC_FRAMEWORK_ROOT}/Resources/WindowsResources.py
+    ${PYTHON_EXECUTABLE} ${ORTHANC_FRAMEWORK_ROOT}/../Resources/WindowsResources.py
     ${PLUGIN_VERSION} "Python plugin" OrthancPython.dll
     "Plugin to create Orthanc plugins using Python"
     ERROR_VARIABLE Failure