diff Azure/CMakeLists.txt @ 89:62752402edbb

azure build for Windows platform
author Alain Mazy <alain@mazy.be>
date Mon, 28 Nov 2022 14:57:54 +0100
parents 431ab61b5760
children 7bf31db5497e
line wrap: on
line diff
--- a/Azure/CMakeLists.txt	Mon Nov 21 08:58:13 2022 +0100
+++ b/Azure/CMakeLists.txt	Mon Nov 28 14:57:54 2022 +0100
@@ -54,7 +54,6 @@
   ${ORTHANC_FRAMEWORK_ROOT}/../../OrthancServer/Plugins/Samples/Common
   )
 
-
 find_package(cryptopp CONFIG REQUIRED)
 
 # Azure stuff (from https://github.com/Microsoft/vcpkg/issues/6277)
@@ -77,13 +76,13 @@
   set (CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} /Zi")
   set (CMAKE_SHARED_LINKER_FLAGS_RELEASE "${CMAKE_SHARED_LINKER_FLAGS_RELEASE} /DEBUG /OPT:REF /OPT:ICF")
 
+  message(INFO "WASTORAGE_INCLUDE_DIR ${WASTORAGE_INCLUDE_DIR}")
+
   add_definitions(-D_NO_WASTORAGE_API=1)   # from https://github.com/Azure/azure-storage-cpp/issues/263
 endif()
 
+include_directories(${WASTORAGE_INCLUDE_DIR})
 
-if (NOT WIN32)
-  include_directories(${WASTORAGE_INCLUDE_DIR})
-endif()
 
 set(COMMON_SOURCES
     ${CMAKE_SOURCE_DIR}/../Common/IStorage.h
@@ -129,7 +128,7 @@
 else()
   target_link_libraries(OrthancAzureBlobStorage
     PRIVATE
-    cryptopp-static
+    cryptopp::cryptopp
     ${OPENSSL_LIBRARY}
     ${WASTORAGE_LIBRARY} 
     ${CPPREST_LIBRARY}