diff Google/CMakeLists.txt @ 101:57be7094d6c5

updated Google plugin for latest SDK
author Alain Mazy <am@osimis.io>
date Thu, 20 Jul 2023 16:14:39 +0200
parents 431ab61b5760
children 5f6cb6dff8f4 0585b5de6be2
line wrap: on
line diff
--- a/Google/CMakeLists.txt	Thu Jul 20 15:58:17 2023 +0200
+++ b/Google/CMakeLists.txt	Thu Jul 20 16:14:39 2023 +0200
@@ -56,9 +56,11 @@
   )
 
 find_package(CURL REQUIRED)
-find_package(storage_client REQUIRED)
+find_package(google_cloud_cpp_storage REQUIRED)
 find_package(cryptopp CONFIG REQUIRED)
 
+set(CMAKE_CXX_STANDARD 14)
+
 set(COMMON_SOURCES
     ${CMAKE_SOURCE_DIR}/../Common/IStorage.h
     ${CMAKE_SOURCE_DIR}/../Common/BaseStorage.h
@@ -91,8 +93,10 @@
 
 target_link_libraries(OrthancGoogleCloudStorage
   PRIVATE
-  storage_client
-  cryptopp-static
+  CURL::libcurl 
+  google-cloud-cpp::storage 
+  google-cloud-cpp::experimental-storage-grpc
+  cryptopp::cryptopp
   )
 
 add_executable(UnitTests
@@ -106,7 +110,9 @@
 
 target_link_libraries(UnitTests
   PRIVATE
-  cryptopp-static
-  storage_client
+  CURL::libcurl 
+  google-cloud-cpp::storage 
+  google-cloud-cpp::experimental-storage-grpc
+  cryptopp::cryptopp
   ${GOOGLE_TEST_LIBRARIES}
   )