diff Azure/CMakeLists.txt @ 15:2a02b21f0a19

migration + storage structure
author Alain Mazy
date Tue, 01 Sep 2020 13:08:49 +0200
parents 987cb95c1aee
children 0e509a47e010 44de9edf2443
line wrap: on
line diff
--- a/Azure/CMakeLists.txt	Wed Aug 26 12:52:37 2020 +0200
+++ b/Azure/CMakeLists.txt	Tue Sep 01 13:08:49 2020 +0200
@@ -7,32 +7,31 @@
 include(CheckIncludeFileCXX)
 
 set(ORTHANC_FRAMEWORK_SOURCE "hg" CACHE STRING "orthanc source")
-set(ORTHANC_FRAMEWORK_VERSION "7176ebf" CACHE STRING "orthanc framework version")
+set(ORTHANC_FRAMEWORK_VERSION "1.7.3" CACHE STRING "orthanc framework version")
 set(ALLOW_DOWNLOADS ON)
 
 # Download and setup the Orthanc framework
 include(${CMAKE_SOURCE_DIR}/../Common/Resources/DownloadOrthancFramework.cmake)
 
-include(${ORTHANC_ROOT}/Resources/CMake/OrthancFrameworkParameters.cmake)
+include(${ORTHANC_FRAMEWORK_ROOT}/../Resources/CMake/OrthancFrameworkParameters.cmake)
 
 set(ENABLE_GOOGLE_TEST ON)
 set(ORTHANC_FRAMEWORK_PLUGIN ON)
 
-include(${ORTHANC_ROOT}/Resources/CMake/OrthancFrameworkConfiguration.cmake)
+include(${ORTHANC_FRAMEWORK_ROOT}/../Resources/CMake/OrthancFrameworkConfiguration.cmake)
 
 
 add_definitions(
     -DHAS_ORTHANC_EXCEPTION=1
-    -DORTHANC_ENABLE_LOGGING_PLUGIN=1
+    -DORTHANC_ENABLE_LOGGING=1
     -DAZURE_STORAGE_PLUGIN=1
     )
 add_definitions(-DPLUGIN_VERSION="${PLUGIN_VERSION}")
 
 include_directories(
-  ${ORTHANC_ROOT}
-  ${ORTHANC_ROOT}/Core
-  ${ORTHANC_ROOT}/Plugins/Include
-  ${ORTHANC_ROOT}/Plugins/Samples/Common
+  ${ORTHANC_FRAMEWORK_ROOT}
+  ${ORTHANC_FRAMEWORK_ROOT}/../../OrthancServer/Plugins/Include
+  ${ORTHANC_FRAMEWORK_ROOT}/../../OrthancServer/Plugins/Samples/Common
   )
 
 
@@ -50,11 +49,13 @@
 
 set(COMMON_SOURCES
     ${CMAKE_SOURCE_DIR}/../Common/IStoragePlugin.h
+    ${CMAKE_SOURCE_DIR}/../Common/BaseStoragePlugin.h
+    ${CMAKE_SOURCE_DIR}/../Common/BaseStoragePlugin.cpp
     ${CMAKE_SOURCE_DIR}/../Common/EncryptionHelpers.cpp
     ${CMAKE_SOURCE_DIR}/../Common/EncryptionHelpers.h
     ${CMAKE_SOURCE_DIR}/../Common/EncryptionConfigurator.cpp
     ${CMAKE_SOURCE_DIR}/../Common/EncryptionConfigurator.h
-    ${ORTHANC_ROOT}/Plugins/Samples/Common/OrthancPluginCppWrapper.cpp
+    ${ORTHANC_FRAMEWORK_ROOT}/../../OrthancServer/Plugins/Samples/Common/OrthancPluginCppWrapper.cpp
 
     ${ORTHANC_CORE_SOURCES}
   )