diff Azure/CMakeLists.txt @ 100:16f0abc677c5

fix Azure win compilation
author Alain Mazy <am@osimis.io>
date Thu, 20 Jul 2023 15:58:17 +0200
parents f4e05641c108
children 57be7094d6c5
line wrap: on
line diff
--- a/Azure/CMakeLists.txt	Thu Jul 20 15:09:57 2023 +0200
+++ b/Azure/CMakeLists.txt	Thu Jul 20 15:58:17 2023 +0200
@@ -121,19 +121,16 @@
   target_link_libraries(OrthancAzureBlobStorage
     PRIVATE
     cryptopp::cryptopp
-    ${WASTORAGE_LIBRARY} 
+    Azure::azure-storage-blobs
     ${UUID_LIBRARY} 
-    ${Boost_LIBRARIES} 
     ${LIBXML2_LIBRARIES} 
-    Azure::azure-storage-blobs
     )
 else()
   target_link_libraries(OrthancAzureBlobStorage
     PRIVATE
+    cryptopp::cryptopp
     Azure::azure-storage-blobs
     ${OPENSSL_LIBRARY}
-    ${WASTORAGE_LIBRARY} 
-    ${CPPREST_LIBRARY} 
     Winhttp.lib
     Crypt32.lib
     xmllite.lib