diff PostgreSQL/CMakeLists.txt @ 460:f0976163dbe1 pg-transactions

integration mainline->pg-transactions
author Sebastien Jodogne <s.jodogne@gmail.com>
date Wed, 24 Jan 2024 15:27:38 +0100
parents f2427f94d879 ecd0b719cff5
children 0d168a2cadec
line wrap: on
line diff
--- a/PostgreSQL/CMakeLists.txt	Wed Jan 24 10:17:01 2024 +0100
+++ b/PostgreSQL/CMakeLists.txt	Wed Jan 24 15:27:38 2024 +0100
@@ -1,8 +1,8 @@
 # Orthanc - A Lightweight, RESTful DICOM Store
 # Copyright (C) 2012-2016 Sebastien Jodogne, Medical Physics
 # Department, University Hospital of Liege, Belgium
-# Copyright (C) 2017-2023 Osimis S.A., Belgium
-# Copyright (C) 2021-2023 Sebastien Jodogne, ICTEAM UCLouvain, Belgium
+# Copyright (C) 2017-2024 Osimis S.A., Belgium
+# Copyright (C) 2021-2024 Sebastien Jodogne, ICTEAM UCLouvain, Belgium
 #
 # This program is free software: you can redistribute it and/or
 # modify it under the terms of the GNU Affero General Public License
@@ -153,9 +153,6 @@
   COMPILE_FLAGS -DORTHANC_ENABLE_LOGGING_PLUGIN=1
   )
 
-DefineSourceBasenameForTarget(OrthancPostgreSQLIndex)
-DefineSourceBasenameForTarget(OrthancPostgreSQLStorage)
- 
 
 install(
   TARGETS OrthancPostgreSQLIndex OrthancPostgreSQLStorage
@@ -181,4 +178,9 @@
   COMPILE_FLAGS -DORTHANC_ENABLE_LOGGING_PLUGIN=0
   )
 
-DefineSourceBasenameForTarget(UnitTests)
+if (COMMAND DefineSourceBasenameForTarget)
+  DefineSourceBasenameForTarget(FrameworkForPlugins)
+  DefineSourceBasenameForTarget(OrthancPostgreSQLIndex)
+  DefineSourceBasenameForTarget(OrthancPostgreSQLStorage)
+  DefineSourceBasenameForTarget(UnitTests)
+endif()