diff MySQL/CMakeLists.txt @ 489:e8b4bb6a33e7

introduction of ORTHANC_SDK_COMPATIBLE_VERSIONS in CMake
author Sebastien Jodogne <s.jodogne@gmail.com>
date Fri, 22 Mar 2024 14:27:36 +0100
parents bba27bbef7e0
children a164d8aebe0e
line wrap: on
line diff
--- a/MySQL/CMakeLists.txt	Fri Mar 08 11:08:31 2024 +0100
+++ b/MySQL/CMakeLists.txt	Fri Mar 22 14:27:36 2024 +0100
@@ -23,8 +23,17 @@
 
 set(ORTHANC_PLUGIN_VERSION "mainline")
 
+# This is the preferred version of the Orthanc SDK for this plugin
 set(ORTHANC_SDK_DEFAULT_VERSION "1.12.0")
 
+# This is the list of the versions of the Orthanc SDK against which
+# this plugin will compile
+set(ORTHANC_SDK_COMPATIBLE_VERSIONS "0.9.5" "1.4.0" "1.5.2" "1.5.4" "1.9.2" "1.12.0" "1.12.3")
+
+# This is the minimal version of the Orthanc runtime that will provide
+# best performance. If the version of the Orthanc runtime is below
+# this minimal version, a warning message will be printed (but the
+# plugin will still start).
 set(ORTHANC_OPTIMAL_VERSION_MAJOR    1)
 set(ORTHANC_OPTIMAL_VERSION_MINOR    12)
 set(ORTHANC_OPTIMAL_VERSION_REVISION 0)